aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <mk@cm4all.com>2008-10-24 08:41:34 +0200
committerMax Kellermann <mk@cm4all.com>2008-10-24 08:41:34 +0200
commit8b4829c2fe10cd4019ba8c352cf1d4d177e8a064 (patch)
treec5f9f558ccf0fe35f648e1a4f873f1fcfa30669a /configure.ac
parent5fefa954a32cb8bae15df12d4ffdfe23c86c3802 (diff)
pcm_resample: support for libsamplerate < 0.1.3
libsamplerate 0.1.2 didn't have the 32 bit <-> float conversion routines. Emulate them in case they aren't supported.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76f4badb..04b2b51c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,11 @@ if test x$enable_lsr = xyes; then
[enable_lsr=no;AC_MSG_WARN([libsamplerate not found -- disabling])])
fi
+if test x$enable_lsr = xyes; then
+ PKG_CHECK_MODULES([SAMPLERATE_013], [samplerate >= 0.1.3],,
+ [AC_DEFINE([HAVE_LIBSAMPLERATE_NOINT], 1, [libsamplerate doesn't provide src_int_to_float_array() (<0.1.3)])])
+fi
+
AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
if test x$enable_fifo = xyes; then