aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGreg Ward <greg@gerg.ca>2010-12-20 22:21:46 -0500
committerMax Kellermann <max@duempel.org>2010-12-21 07:36:28 +0100
commit80dc6021931e12cb465a46f7b61e7aef19012080 (patch)
tree551600c9126bc32f5d875ee5b10f1071eec7559c /configure.ac
parentc7f5a8725879a9d6137d186bf6f827162ae88511 (diff)
osx_output: allow user to specify other audio devices.
Add new config parameter 'device' to audio_output type "osx": - if not supplied or set to "default", open default device - if set to "system", open system device - otherwise 'device' should be an audio device name: mpd will find and open the specified audio device, falling back to the default device if it's not found
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ab1410db..d8b2c583 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1319,7 +1319,7 @@ enable_osx=no
case "$host_os" in
darwin*)
AC_DEFINE(HAVE_OSX, 1, [Define for compiling OS X support])
- MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreServices"
+ MPD_LIBS="$MPD_LIBS -framework AudioUnit -framework CoreAudio -framework CoreServices"
enable_osx=yes ;;
esac