aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-10-03 21:07:55 +0200
committerMax Kellermann <max@duempel.org>2010-10-27 21:25:41 +0200
commit75f4772ba2584a3d533ee11fb210201d45f64bb6 (patch)
treefd9c9f6e3c534419ce03d13d7854b5979b6c0c84 /configure.ac
parentfe1b626f760d5c5e0726befb1c243f4a901613a6 (diff)
output: new output plugin "ffado"
Using libffado, to play on firewire audio devices. Warning: this plugin was not tested successfully. I just couldn't keep libffado2 from crashing. Use at your own risk. For details, see my Debian bug reports: http://bugs.debian.org/601657 http://bugs.debian.org/601659
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c5984501..94221506 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,10 @@ AC_ARG_ENABLE(documentation,
[build documentation (default: disable)]),,
[enable_documentation=no])
+AC_ARG_ENABLE(ffado,
+ AS_HELP_STRING([--enable-ffado], [enable libffado (FireWire) support]),,
+ [enable_ffado=auto])
+
AC_ARG_ENABLE(ffmpeg,
AS_HELP_STRING([--enable-ffmpeg],
[enable FFMPEG support]),,
@@ -1205,6 +1209,17 @@ fi
AM_CONDITIONAL(HAVE_ALSA, test x$enable_alsa = xyes)
+dnl ----------------------------------- FFADO ---------------------------------
+
+MPD_AUTO_PKG(ffado, FFADO, [libffado],
+ [libffado output plugin], [libffado not found])
+
+if test x$enable_ffado = xyes; then
+ AC_DEFINE(ENABLE_FFADO_OUTPUT, 1, [Define to enable the libffado output plugin])
+fi
+
+AM_CONDITIONAL(ENABLE_FFADO_OUTPUT, test x$enable_ffado = xyes)
+
dnl ----------------------------------- FIFO ----------------------------------
if test x$enable_fifo = xyes; then
AC_CHECK_FUNC([mkfifo],
@@ -1395,6 +1410,7 @@ dnl --------------------- Post Audio Output Plugins Tests ---------------------
if
test x$enable_alsa = xno &&
test x$enable_ao = xno &&
+ test x$enable_ffado = xno &&
test x$enable_fifo = xno &&
test x$enable_httpd_output = xno &&
test x$enable_jack = xno &&
@@ -1529,6 +1545,7 @@ results(id3,[ID3])
echo -en '\nPlayback support:\n\t'
results(alsa,ALSA)
+results(ffado,FFADO)
results(fifo,FIFO)
results(recorder_output,[File Recorder])
results(httpd_output,[HTTP Daemon])