aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-10-23 20:00:51 +0200
committerMax Kellermann <max@duempel.org>2008-10-23 20:00:51 +0200
commit6b1c54ef9646abddfbd4960c207b32426300a90c (patch)
tree5b3ae6bf5fc377cf9c705c85948ab5b85e31743c /configure.ac
parent098991f8e8a974d2eee39645fa23c43a4c8b06c1 (diff)
pcm_utils: moved code to pcm_resample.c
Separate the resampling code from the rest of pcm_utils.c. Create two sub-libraries: pcm_resample_libsamplerate.c and pcm_resample_fallback.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fdec792..76f4badb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -390,6 +390,8 @@ if test x$enable_lsr = xyes; then
[enable_lsr=no;AC_MSG_WARN([libsamplerate not found -- disabling])])
fi
+AM_CONDITIONAL(HAVE_LIBSAMPLERATE, test x$enable_lsr = xyes)
+
if test x$enable_fifo = xyes; then
AC_CHECK_FUNC([mkfifo],
[enable_fifo=yes;AC_DEFINE([HAVE_FIFO], 1, [Define to enable support for writing audio to a FIFO])],