aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-10-06 22:45:02 +0200
committerMax Kellermann <max@duempel.org>2011-10-06 22:45:02 +0200
commit5c0576ca5519d525c6c383cd138da917b67a2810 (patch)
tree08a6f4b78ec2769265bb210e408a46b36f78be61 /configure.ac
parent4e909f94113360933b77cf9e67ec54649d48665f (diff)
parent039b3544902fe479fa2ce31f06de2c08377e0fc5 (diff)
Merge branch 'v0.16.x'
Conflicts: configure.ac src/player_control.c src/player_thread.c src/playlist_song.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18e7e471..98062eea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ AM_CONDITIONAL(HAVE_CXX, test x$HAVE_CXX = xyes)
AC_PROG_INSTALL
AC_PROG_MAKE_SET
PKG_PROG_PKG_CONFIG
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [], [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
dnl ---------------------------------------------------------------------------
dnl Declare Variables
@@ -1617,5 +1624,6 @@ dnl Generate files
dnl ---------------------------------------------------------------------------
AC_OUTPUT(Makefile)
AC_OUTPUT(doc/doxygen.conf)
+AC_OUTPUT(mpd.service)
echo 'MPD is ready for compilation, type "make" to begin.'