aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUlrich Spörlein <uqs@spoerlein.net>2011-02-08 05:44:00 +0100
committerMax Kellermann <max@duempel.org>2011-03-09 19:50:54 +0100
commit5779146a7feed41f107b3865226134579a66135a (patch)
treeb850f753aeb0cd59e91a604c2b5f954c46b20501 /configure.ac
parenta1d1c2beaa54f76bbf92b2a5fd83c4a582a0316b (diff)
configure.ac: fix bashism in tremor test
This makes FreeBSD detect libogg correctly. The '==' operator is an undocumented GNU extension to test(1) and cannot be relied upon to exist and do the right thing. POSIX mandates string comparisons to be done using "test foo = bar".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4fafb189..52740b0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -635,7 +635,7 @@ fi
AM_CONDITIONAL(ENABLE_LASTFM, test x$enable_lastfm = xyes)
dnl ---------------------------------- libogg ---------------------------------
-if test x$with_tremor == xno || test -z $with_tremor; then
+if test x$with_tremor = xno || test -z $with_tremor; then
PKG_CHECK_MODULES(OGG, [ogg], enable_ogg=yes, enable_ogg=no)
fi