aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-08-29 09:21:00 +0200
committerMax Kellermann <max@duempel.org>2011-08-29 09:39:03 +0200
commit453368078be8e79955a66ea9ca63efd6c3095850 (patch)
tree9d5cb916a3078600af64024371a09ec206487802 /configure.ac
parent6e3b643bdf5f96c63c65dd83cfe6e19161fa0724 (diff)
configure.ac: add OpenSSL check for RAOP output plugin
Auto-enable the plugin when OpenSSL was found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c1f76e93..46d592bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -213,7 +213,7 @@ AC_ARG_ENABLE(httpd-output,
AC_ARG_ENABLE(raop-output,
AS_HELP_STRING([--enable-raop-output],
[enables the RAOP output]),,
- [enable_raop_output=no])
+ [enable_raop_output=auto])
AC_ARG_ENABLE(id3,
AS_HELP_STRING([--disable-id3],
@@ -1441,9 +1441,11 @@ AM_CONDITIONAL(ENABLE_SOLARIS_OUTPUT, test x$enable_solaris_output = xyes)
dnl --------------------------------- RAOP ------------------------------------
+MPD_AUTO_PKG(raop_output, OPENSSL, [openssl],
+ [RAOP output], [OpenSSL not found])
+
if test x$enable_raop_output = xyes; then
- AC_DEFINE(ENABLE_RAOP_OUTPUT, 1, [Define for compiling RAOP support])
- MPD_LIBS="$MPD_LIBS -lssl -lcrypto"
+ AC_DEFINE(ENABLE_RAOP_OUTPUT, 1, [Define for compiling RAOP support])
fi
AM_CONDITIONAL(ENABLE_RAOP_OUTPUT, test x$enable_raop_output = xyes)