aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-08-24 03:23:12 +0200
committerMax Kellermann <max@duempel.org>2011-08-24 03:33:49 +0200
commit3b9ffea36f2079fe23e301d0298ca957ce6a7158 (patch)
tree6441bda296152883cf1ebc9296b6a41d5f4f0712 /configure.ac
parente242f3999c7f0219926877e4accf4763fec2972c (diff)
input/soup: new input plugin based on libsoup
To demonstrate the new I/O thread. libsoup is well-integrated into the GLib main loop, which made this plugin pretty easy to write. As a side effect, we have to initialize the I/O thread in all debug programs that use the input API.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84adf4d7..c1f76e93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,11 @@ AC_ARG_ENABLE(curl,
[enable support for libcurl HTTP streaming (default: auto)]),,
[enable_curl=auto])
+AC_ARG_ENABLE(soup,
+ AS_HELP_STRING([--enable-soup],
+ [enable support for libsoup HTTP streaming (default: auto)]),,
+ [enable_soup=auto])
+
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[enable debugging (default: disabled)]),,
@@ -644,6 +649,14 @@ if test x$enable_curl = xyes; then
fi
AM_CONDITIONAL(ENABLE_CURL, test x$enable_curl = xyes)
+dnl ----------------------------------- SOUP ----------------------------------
+MPD_AUTO_PKG(soup, SOUP, [libsoup-2.4],
+ [libsoup HTTP streaming], [libsoup not found])
+if test x$enable_soup = xyes; then
+ AC_DEFINE(ENABLE_SOUP, 1, [Define when libsoup is used for HTTP streaming])
+fi
+AM_CONDITIONAL(ENABLE_SOUP, test x$enable_soup = xyes)
+
dnl --------------------------------- Last.FM ---------------------------------
if test x$enable_lastfm = xyes; then
if test x$enable_curl != xyes; then
@@ -1625,6 +1638,7 @@ fi
printf '\nStreaming support:\n\t'
results(curl,[CURL])
+results(soup, [SOUP])
results(lastfm,[Last.FM])
results(mms,[MMS])
results(cdio_paranoia, [CDIO_PARANOIA])