aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-09-25 22:03:44 +0200
committerMax Kellermann <max@duempel.org>2012-09-25 22:03:44 +0200
commit33364edfb3ed349c0a05d55e0449bfc0a9a701be (patch)
tree093a8e3fc88ccfdfac9a8e7b2bcd7d3f6d9ee020 /configure.ac
parent5e9ccdec639a7b3e6b3e25c1fcac5270f8c5005c (diff)
decoder/adplug: new decoder plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 702980a2..80cd64fd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -150,6 +150,11 @@ AC_ARG_ENABLE(mpdclient,
[enable support for the MPD client]),,
enable_libmpdclient=auto)
+AC_ARG_ENABLE(adplug,
+ AS_HELP_STRING([--enable-adplug],
+ [enable the AdPlug decoder plugin (default: auto)]),,
+ enable_adplug=auto)
+
AC_ARG_ENABLE(alsa,
AS_HELP_STRING([--enable-alsa], [enable ALSA support]),,
[enable_alsa=auto])
@@ -823,6 +828,14 @@ dnl ---------------------------------------------------------------------------
dnl Decoder Plugins
dnl ---------------------------------------------------------------------------
+dnl -------------------------------- libadplug --------------------------------
+MPD_AUTO_PKG(adplug, ADPLUG, [adplug],
+ [AdPlug decoder plugin], [libadplug not found])
+if test x$enable_adplug = xyes; then
+ AC_DEFINE(HAVE_ADPLUG, 1, [Define to use libadplug])
+fi
+AM_CONDITIONAL(HAVE_ADPLUG, test x$enable_adplug = xyes)
+
dnl -------------------------------- audiofile --------------------------------
MPD_AUTO_PKG(audiofile, AUDIOFILE, [audiofile >= 0.1.7],
[audiofile decoder plugin], [libaudiofile not found])