aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-01-10 11:47:14 +0100
committerMax Kellermann <max@duempel.org>2011-01-10 11:47:14 +0100
commit2b29ca796edfc765b498463dac732663142911f2 (patch)
treebb71702b20181e5f96bf64c95facc164deb19736 /configure.ac
parent51840088128a25a642744db3a2bff380952ca375 (diff)
parent9ad862d3a6f0cbb043bf4f9ff97e54e5c606ad3e (diff)
Merge commit 'release-0.16.1'
Conflicts: NEWS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 1 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index a4ebde3a..af5356f2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,7 @@ dnl Programs
dnl ---------------------------------------------------------------------------
AC_PROG_CC_C99
AC_PROG_CXX
+AC_PROG_RANLIB
HAVE_CXX=yes
if test x$CXX = xg++; then
@@ -864,15 +865,6 @@ if test x$enable_modplug = xyes; then
fi
AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
-dnl --------------------------- sndfile/modplug test --------------------------
-if test x$enable_sndfile = xauto && test x$enable_modplug = xyes; then
- dnl If modplug is enabled, enable sndfile only if explicitly
- dnl requested - modplug's modplug/sndfile.h is known to
- dnl conflict with libsndfile's sndfile.h.
- AC_MSG_NOTICE([disabling libsndfile auto-detection, because the modplug decoder is enabled])
- enable_sndfile=no
-fi
-
dnl -------------------------------- libsndfile -------------------------------
dnl See above test, which may disable this.
MPD_AUTO_PKG(sndfile, SNDFILE, [sndfile],
@@ -1598,11 +1590,6 @@ results(cdio_paranoia, [CDIO_PARANOIA])
printf '\n\n##########################################\n\n'
-if test x$enable_sndfile = xyes && test x$enable_modplug = xyes; then
- AC_MSG_WARN([compilation may fail, because libmodplug conflicts with libsndfile])
- AC_MSG_WARN([libmodplug ships modplug/sndfile.h, which hides libsndfile's sndfile.h])
-fi
-
echo 'Generating files needed for compilation'
dnl ---------------------------------------------------------------------------