aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-29 22:40:11 +0100
committerMax Kellermann <max@duempel.org>2013-01-29 22:54:56 +0100
commitfa34dd7bd3e0222811010dda6d1b40c4e3b3291b (patch)
treeda4578703167d94c8d0558f235b2743e7648ad61 /Makefile.am
parent9f0fb8f6a8f58ff9a760d40bccfadd010b9ddef9 (diff)
test/visit_archive: new debug program
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c3b52ebd..a1e43040 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1038,6 +1038,10 @@ noinst_PROGRAMS = \
test/run_normalize \
test/software_volume
+if ENABLE_ARCHIVE
+noinst_PROGRAMS += test/visit_archive
+endif
+
if HAVE_ID3TAG
noinst_PROGRAMS += test/dump_rva2
endif
@@ -1089,6 +1093,28 @@ test_run_input_SOURCES = test/run_input.cxx \
src/uri.c \
src/fd_util.c
+if ENABLE_ARCHIVE
+
+test_visit_archive_LDADD = \
+ $(INPUT_LIBS) \
+ $(ARCHIVE_LIBS) \
+ libevent.a \
+ libfs.a \
+ $(GLIB_LIBS)
+test_visit_archive_SOURCES = test/visit_archive.cxx \
+ src/IOThread.cxx \
+ src/InputStream.cxx \
+ src/ConfigFile.cxx src/tokenizer.c src/utils.c src/string_util.c \
+ src/Tag.cxx src/TagNames.c src/TagPool.cxx \
+ src/uri.c \
+ src/fd_util.c
+
+if ENABLE_DESPOTIFY
+test_visit_archive_SOURCES += src/DespotifyUtils.cxx
+endif
+
+endif
+
test_dump_text_file_LDADD = \
$(INPUT_LIBS) \
$(ARCHIVE_LIBS) \