aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-06 22:50:07 +0200
committerMax Kellermann <max@duempel.org>2009-07-15 16:59:06 +0200
commitf0157f6fa1bffd3510b5df63bb073d25e0f11307 (patch)
tree5706ace4a9bbf2d600ed187a1c5868bc3cdcb1a5 /Makefile.am
parent966a886ef5784e0525b91c3eec1b9b32e2b1c646 (diff)
Makefile.am: disable test/run_encoder without plugins
If the encoder plugin API is disabled at compile time, don't compile test/run_encoder.c.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d02eeb12..aadeb250 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -599,7 +599,6 @@ noinst_PROGRAMS = \
test/run_input \
test/run_decoder \
test/read_tags \
- test/run_encoder \
test/run_output \
test/read_mixer \
test/software_volume
@@ -662,6 +661,8 @@ test_read_tags_SOURCES = test/read_tags.c \
$(TAG_SRC) \
$(DECODER_SRC)
+if ENABLE_ENCODER
+noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.c \
src/conf.c src/buffer2array.c \
src/utils.c \
@@ -671,6 +672,7 @@ test_run_encoder_SOURCES = test/run_encoder.c \
test_run_encoder_LDADD = $(MPD_LIBS) \
$(ENCODER_LIBS) \
$(GLIB_LIBS)
+endif
test_software_volume_SOURCES = test/software_volume.c \
src/audio_parser.c \