aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDenis Krjuchkov <alcohold@gmail.com>2010-09-20 18:28:08 -0700
committerMax Kellermann <max@duempel.org>2010-09-23 20:42:33 +0200
commite8ebb1af91435674784dcbbc3207331fcdac7458 (patch)
tree9a5a88a8704396a3c3e617a26cc8f905b75cfc8f /Makefile.am
parent9fa3d7c4fa57dbc24a8e80b1bf1be9e2033133c8 (diff)
main: Add Windows Service support
I've added PIPE_EVENT_SHUTDOWN because calling g_main_loop_quit() do not work when called from another thread. Main thread was sleeping in g_poll() so I needed some way to wake it up. By some strange reason call close(event_pipe[0]) in event_pipe_deinit() hangs. In current implementation that code never reached so that was not a problem :-) I've added a conditional to leave event_pipe[0] open on Win32.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 01abe578..eeeffc90 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -278,6 +278,7 @@ src_mpd_SOURCES = \
src/log.c \
src/ls.c \
src/main.c \
+ src/main_win32.c \
src/event_pipe.c \
src/daemon.c \
src/AudioCompress/compress.c \