aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-04-05 00:45:39 +0200
committerMax Kellermann <max@duempel.org>2012-04-05 00:45:39 +0200
commitc22cbbf8280bb35c8fee5ae3931d3bc08b70099f (patch)
tree4654b9834f51c32746e2f72ce64191149647d87e /Makefile.am
parentf930f37d35995f0fc07f70aefc41babc0db1757e (diff)
parent5acee73fc85e44179120a5818247fc0760038cff (diff)
Merge branch 'v0.16.x'
Conflicts: src/output/osx_plugin.c src/text_input_stream.c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 75da9969..38d08f09 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1170,6 +1170,27 @@ test_run_encoder_LDADD = \
$(GLIB_LIBS)
endif
+if ENABLE_VORBIS_ENCODER
+noinst_PROGRAMS += test/test_vorbis_encoder
+test_test_vorbis_encoder_SOURCES = test/test_vorbis_encoder.c \
+ test/stdbin.h \
+ src/conf.c src/tokenizer.c \
+ src/utils.c \
+ src/string_util.c \
+ src/tag.c src/tag_pool.c \
+ src/audio_check.c \
+ src/audio_format.c \
+ src/audio_parser.c \
+ src/pcm_buffer.c \
+ src/fifo_buffer.c src/growing_fifo.c \
+ $(ENCODER_SRC)
+test_test_vorbis_encoder_CPPFLAGS = $(AM_CPPFLAGS) \
+ $(ENCODER_CFLAGS)
+test_test_vorbis_encoder_LDADD = $(MPD_LIBS) \
+ $(ENCODER_LIBS) \
+ $(GLIB_LIBS)
+endif
+
test_software_volume_SOURCES = test/software_volume.c \
test/stdbin.h \
src/audio_check.c \