aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-27 22:18:45 +0100
committerMax Kellermann <max@duempel.org>2013-01-27 22:38:14 +0100
commit95c3f57b3027e0961a1e32036dcce0383fb5e6ee (patch)
treed9279be8c6c3bd46f95b674e8e59a84879f8de34 /Makefile.am
parent068f191c0d9459554db536ac3d7f64f9b9338381 (diff)
zeroconf: convert to C++
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index ee57c752..cf023a6b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,7 +117,6 @@ mpd_headers = \
src/uri.h \
src/utils.h \
src/string_util.h \
- src/zeroconf.h src/zeroconf-internal.h \
src/timer.h \
src/mpd_error.h
@@ -681,14 +680,16 @@ endif
if HAVE_ZEROCONF
-src_mpd_SOURCES += src/zeroconf.c
+src_mpd_SOURCES += \
+ src/ZeroconfInternal.hxx \
+ src/ZeroconfGlue.cxx src/ZeroconfGlue.hxx
if HAVE_AVAHI
-src_mpd_SOURCES += src/zeroconf-avahi.c
+src_mpd_SOURCES += src/ZeroconfAvahi.cxx src/ZeroconfAvahi.hxx
endif
if HAVE_BONJOUR
-src_mpd_SOURCES += src/zeroconf-bonjour.c
+src_mpd_SOURCES += src/ZeroconfBonjour.cxx src/ZeroconfBonjour.hxx
endif
endif