aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-01-24 19:18:58 +0100
committerMax Kellermann <max@duempel.org>2013-01-24 19:18:58 +0100
commit94fffb332bb40eb4b13ad7a2039109d2a420a8f6 (patch)
tree6686e1d74a1dcbe4e91c70aef45374256d7acac9 /Makefile.am
parentdc2e64c92b5a61f4c578b5d4c6017b0d5b8037ff (diff)
archive/*: convert to C++
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am29
1 files changed, 14 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 852c2870..b900b24d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -130,14 +130,6 @@ mpd_headers = \
src/string_util.h \
src/zeroconf.h src/zeroconf-internal.h \
src/timer.h \
- src/archive_api.h \
- src/archive_internal.h \
- src/archive_list.h \
- src/archive_plugin.h \
- src/archive/bz2_archive_plugin.h \
- src/archive/iso9660_archive_plugin.h \
- src/archive/zzip_archive_plugin.h \
- src/input/archive_input_plugin.h \
src/mpd_error.h
src_mpd_SOURCES = \
@@ -414,10 +406,11 @@ src_mpd_SOURCES += \
src/UpdateArchive.cxx src/UpdateArchive.hxx
libarchive_a_SOURCES = \
- src/archive_api.c \
- src/archive_list.c \
- src/archive_plugin.c \
- src/input/archive_input_plugin.c
+ src/ArchiveLookup.cxx src/ArchiveLookup.hxx \
+ src/ArchiveList.cxx src/ArchiveList.hxx \
+ src/ArchivePlugin.cxx src/ArchivePlugin.hxx \
+ src/ArchiveInternal.hxx \
+ src/input/ArchiveInputPlugin.cxx src/input/ArchiveInputPlugin.hxx
libarchive_a_CPPFLAGS = $(AM_CPPFLAGS) \
$(BZ2_CFLAGS) \
$(ISO9660_CFLAGS) \
@@ -430,15 +423,21 @@ ARCHIVE_LIBS = \
$(ZZIP_LIBS)
if HAVE_BZ2
-libarchive_a_SOURCES += src/archive/bz2_archive_plugin.c
+libarchive_a_SOURCES += \
+ src/archive/Bzip2ArchivePlugin.cxx \
+ src/archive/Bzip2ArchivePlugin.hxx
endif
if HAVE_ZZIP
-libarchive_a_SOURCES += src/archive/zzip_archive_plugin.c
+libarchive_a_SOURCES += \
+ src/archive/ZzipArchivePlugin.cxx \
+ src/archive/ZzipArchivePlugin.hxx
endif
if HAVE_ISO9660
-libarchive_a_SOURCES += src/archive/iso9660_archive_plugin.c
+libarchive_a_SOURCES += \
+ src/archive/Iso9660ArchivePlugin.cxx \
+ src/archive/Iso9660ArchivePlugin.hxx
endif
else