aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-09-05 23:03:05 +0200
committerMax Kellermann <max@duempel.org>2011-09-10 07:58:43 +0200
commit7819aa6b2060b600b9ec2471f250038eeebae523 (patch)
treea1523f90ee693f5adba207c208bea81b8466e3b9 /Makefile.am
parent7cc6b63aac5a355bc2dd216d41ce4dc0e0fc3066 (diff)
db_plugin: introducing a plugin API for the song database
First draft, not really pluggable currently - hard-coded to use the "simple" plugin, and calls several of its internal functions. The API is very simple currently, all searches are still performed over the root "directory" object. Future changes to the API will move those search implementations into the plugin, to allow more efficient implementations, or implementations that don't have the whole tree in memory all the time.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ae4c4a7c..fd34b74e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -272,6 +272,8 @@ src_mpd_SOURCES = \
src/database.c \
src/db_save.c src/db_save.h \
src/db_print.c src/db_print.h \
+ src/db_plugin.h \
+ src/db/simple_db_plugin.c src/db/simple_db_plugin.h \
src/dirvec.c \
src/exclude.c \
src/fd_util.c \