aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-02-11 19:12:02 +0100
committerMax Kellermann <max@duempel.org>2012-02-11 17:04:29 +0100
commit5d73215a8dad922c8e383f3837f3ec9e26503389 (patch)
tree8fc4b96d93a907054a05d3250f97bf4f68c6df85 /Makefile.am
parentb7356bc526dbbd6fa00d40caff2addec10ae7c7e (diff)
decoder_plugin: scan tags with callback table
Pass a callback table to scan_file() and scan_stream(), instead of returning a tag object.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 2b98e6ba..636bf064 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -335,6 +335,7 @@ src_mpd_SOURCES = \
src/tag_pool.c \
src/tag_print.c \
src/tag_save.c \
+ src/tag_handler.c src/tag_handler.h \
src/tokenizer.c \
src/text_file.c \
src/text_input_stream.c \
@@ -1006,6 +1007,7 @@ test_dump_playlist_SOURCES = test/dump_playlist.c \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c\
src/uri.c \
src/song.c src/tag.c src/tag_pool.c src/tag_save.c \
+ src/tag_handler.c \
src/text_input_stream.c src/fifo_buffer.c \
src/cue/cue_parser.c src/cue/cue_parser.h \
src/fd_util.c
@@ -1027,7 +1029,7 @@ test_run_decoder_SOURCES = test/run_decoder.c \
test/stdbin.h \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
- src/tag.c src/tag_pool.c \
+ src/tag.c src/tag_pool.c src/tag_handler.c \
src/replay_gain_info.c \
src/uri.c \
src/fd_util.c \
@@ -1049,7 +1051,7 @@ test_read_tags_LDADD = \
test_read_tags_SOURCES = test/read_tags.c \
src/io_thread.c src/io_thread.h \
src/conf.c src/tokenizer.c src/utils.c src/string_util.c src/log.c \
- src/tag.c src/tag_pool.c \
+ src/tag.c src/tag_pool.c src/tag_handler.c \
src/replay_gain_info.c \
src/uri.c \
src/fd_util.c \