aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-08-15 19:52:32 +0200
committerMax Kellermann <max@duempel.org>2012-08-15 23:10:00 +0200
commit2bd344549b5cfcb6d9a1e1e092c034e68d3071bc (patch)
tree26ce785fc374cdad0ba1ed3e09ad6c4329ddcb68 /Makefile.am
parente96779de48be1f1b0080a8e1cfa89756c40e562d (diff)
queue: duplicate all song objects
Make sure the queue "owns" all song objects, so nobody else can free them.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 51dd7fd8..dff597fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1351,6 +1351,7 @@ test_test_pcm_LDADD = \
test_test_queue_priority_SOURCES = \
src/queue.c \
+ test/FakeSong.cxx \
test/test_queue_priority.c
test_test_queue_priority_LDADD = \
$(GLIB_LIBS)