aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-07-25 14:02:10 +0200
committerMax Kellermann <max@duempel.org>2010-07-25 14:02:10 +0200
commit12f4225d6ba6ecf2b989719a287f8ed1f7fb6bf5 (patch)
treea56514b12741845ff5817519fb1cf69ab0c1e6a4 /Makefile.am
parent50862a1dd1b93e2ef12b588a11d8d7cf3bf4075b (diff)
Makefile.am: fix out-of-tree doxygen call
This hack creates a copy of doc/doxygen.conf with the INPUT setting replaced.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1a84cbbd..ec38cf4e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1102,7 +1102,8 @@ endif
doc/api/html/index.html: doc/doxygen.conf
@mkdir -p $(@D)
- $(DOXYGEN) $<
+ [ "$(srcdir)" = "." ] || sed '/INPUT *=/ s/\([^ ]\+\/\)/$(subst /,\/,$(srcdir))\/\1/g' $(srcdir)/doc/doxygen.conf >doc/doxygen.conf
+ $(DOXYGEN) doc/doxygen.conf
all-local: $(DOCBOOK_HTML) doc/api/html/index.html