summaryrefslogtreecommitdiff
path: root/libavformat/swfenc.c
Commit message (Collapse)AuthorAge
* lavf: replace AVStream.codec with AVStream.codecparAnton Khirnov2016-02-23
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, AVStream contains an embedded AVCodecContext instance, which is used by demuxers to export stream parameters to the caller and by muxers to receive stream parameters from the caller. It is also used internally as the codec context that is passed to parsers. In addition, it is also widely used by the callers as the decoding (when demuxer) or encoding (when muxing) context, though this has been officially discouraged since Libav 11. There are multiple important problems with this approach: - the fields in AVCodecContext are in general one of * stream parameters * codec options * codec state However, it's not clear which ones are which. It is consequently unclear which fields are a demuxer allowed to set or a muxer allowed to read. This leads to erratic behaviour depending on whether decoding or encoding is being performed or not (and whether it uses the AVStream embedded codec context). - various synchronization issues arising from the fact that the same context is used by several different APIs (muxers/demuxers, parsers, bitstream filters and encoders/decoders) simultaneously, with there being no clear rules for who can modify what and the different processes being typically delayed with respect to each other. - avformat_find_stream_info() making it necessary to support opening and closing a single codec context multiple times, thus complicating the semantics of freeing various allocated objects in the codec context. Those problems are resolved by replacing the AVStream embedded codec context with a newly added AVCodecParameters instance, which stores only the stream parameters exported by the demuxers or read by the muxers.
* lavf: Explicitly convert types at function pointer assignmentDiego Biurrun2015-03-11
| | | | This fixes a number of "assignment from incompatible pointer type" warnings.
* lavf: switch to AVStream.time_base as the hint for the muxer timebaseAnton Khirnov2014-06-18
| | | | | | | | | | | | Previously, AVStream.codec.time_base was used for that purpose, which was quite confusing for the callers. This change also opens the path for removing AVStream.codec. The change in the lavf-mkv test is due to the native timebase (1/1000) being used instead of the default one (1/90000), so the packets are now sent to the crc muxer in the same order in which they are demuxed (previously some of them got reordered because of inexact timestamp conversion).
* lavf: Don't explicitly flush after each written packet in muxersClément Bœsch2013-09-16
| | | | | | | | Since 596e5d4783, this is not necessary anymore. It also allows to actually disable the flushing, improving write performance (but possibly giving worse latency in real-time streaming). Signed-off-by: Martin Storsjö <martin@martin.st>
* cosmetics: Add '0' to float constants ending in '.'.Diego Biurrun2013-07-25
|
* swfenc: error out for more than 1 audio or video streamJanne Grunau2012-10-09
| | | | Prevents CID602000.
* lavf: flush the output AVIOContext in av_write_trailer().Anton Khirnov2012-09-15
| | | | | | | This is consistent with stdio and is what we want to do in all cases. Fixes a bug in the voc muxer which didn't flush in write_trailer() previously. This is the cause of the change in the test results.
* swf: Move shared table out of the header fileDiego Biurrun2012-08-09
|
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* Improve descriptiveness of a number of codec and container long namesDiego Biurrun2012-07-30
|
* avformat: Add a flag to mark muxers that allow (non strict) monotone timestamps.James Zern2012-05-20
| | | | Signed-off-by: Justin Ruggles <justin.ruggles@gmail.com>
* swfenc: use av_get_audio_frame_duration() instead of AVCodecContext.frame_sizeJustin Ruggles2012-03-05
| | | | | This way we can do stream copy without having the demuxer wait until frame_size has been set.
* lavf: use designated initialisers for all (de)muxers.Anton Khirnov2011-07-17
| | | | It's more readable and less prone to breakage.
* avio: introduce an AVIOContext.seekable fieldAnton Khirnov2011-04-03
| | | | Use it instead of url_is_streamed and AVIOContext.is_streamed.
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* avio: rename put_flush_packet -> avio_flushAnton Khirnov2011-03-16
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: add avio_tell macro as a replacement for url_ftellAnton Khirnov2011-03-04
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: avio_ prefix for url_fseekAnton Khirnov2011-03-01
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* lavf: replace remaining uses of put_tag with avio_writeAnton Khirnov2011-02-25
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: avio: avio_ prefixes for put_* functionsAnton Khirnov2011-02-21
| | | | | | | | | | | | In the name of consistency: put_byte -> avio_w8 put_<type> -> avio_w<type> put_buffer -> avio_write put_nbyte will be made private put_tag will be merged with avio_put_str Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: rename ByteIOContext to AVIOContext.Anton Khirnov2011-02-20
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.Diego Elio Pettenò2011-01-26
| | | | | This also lists the objects from those two libraries as internal (by adding the ff_ prefix) so that they can then be hidden via linker scripts.
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add ff_ prefixes to exported symbols in libavformat/riff.h.Daniel Verkamp2009-06-22
| | | | | | patch by Daniel Verkamp, aniel drv nu Originally committed as revision 19254 to svn://svn.ffmpeg.org/ffmpeg/trunk
* check av_fifo_alloc returnBaptiste Coudurier2009-05-21
| | | | Originally committed as revision 18892 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename pbBufPtr() to put_bits_ptr().Stefano Sabatini2009-04-13
| | | | | | | The new name is more readable and consistent with the FFmpeg naming style. Originally committed as revision 18497 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split bitstream.h, put the bitstream writer stuff in the new fileStefano Sabatini2009-04-12
| | | | | | put_bits.h. Originally committed as revision 18461 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reorder arguments for av_fifo_generic_read to be more logical andReimar Döffinger2009-03-09
| | | | | | consistent with av_fifo_generic_write. Originally committed as revision 17914 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Allocate AVFifoBuffer through the fifo API to reduce future API/ABI issues.Michael Niedermayer2009-03-08
| | | | | | | Yes this breaks ABI/API but ive already broken it and will bump avutil major soon. Originally committed as revision 17869 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove const qualifier from function argument to eliminate the warningDiego Biurrun2009-02-08
| | | | | | swfenc.c:452: warning: passing argument 2 of #av_fifo_generic_write# discards qualifiers from pointer target type Originally committed as revision 17036 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics: Remove pointless period after copyright statement non-sentences.Diego Biurrun2009-01-19
| | | | Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change semantic of CONFIG_*, HAVE_* and ARCH_*.Aurelien Jacobs2009-01-13
| | | | | | They are now always defined to either 0 or 1. Originally committed as revision 16590 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove offset_t typedef and use int64_t directly instead.Diego Biurrun2008-10-03
| | | | | | | The name offset_t is easily confused with the standard off_t type and *_t is POSIX reserved namespace if any POSIX header is included. Originally committed as revision 15533 to svn://svn.ffmpeg.org/ffmpeg/trunk
* update swf video frame number when muxing done, fix #439Baptiste Coudurier2008-07-19
| | | | Originally committed as revision 14293 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.Stefano Sabatini2008-06-03
| | | | | | | patch by Stefano Sabatini, stefano.sabatini-lala poste.it along with some spelling/consistency fixes for the long names by me Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
* use internal video frame numberBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13479 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmeticsBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13478 to svn://svn.ffmpeg.org/ffmpeg/trunk
* simplify, use pointer to codec context in struct instead of only idBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13476 to svn://svn.ffmpeg.org/ffmpeg/trunk
* use AVFifoBufferBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13462 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmeticsBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13461 to svn://svn.ffmpeg.org/ffmpeg/trunk
* merge init and declarationBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13460 to svn://svn.ffmpeg.org/ffmpeg/trunk
* simplify and use version insteadBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13459 to svn://svn.ffmpeg.org/ffmpeg/trunk
* simplifyBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13458 to svn://svn.ffmpeg.org/ffmpeg/trunk
* simplifyBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13457 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics, remove useless cases and bracesBaptiste Coudurier2008-05-27
| | | | Originally committed as revision 13456 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics, remove useless dotBaptiste Coudurier2008-05-26
| | | | Originally committed as revision 13421 to svn://svn.ffmpeg.org/ffmpeg/trunk
* remove useless/obsolete commentsBaptiste Coudurier2008-05-20
| | | | Originally committed as revision 13205 to svn://svn.ffmpeg.org/ffmpeg/trunk
* split swf de/muxerBaptiste Coudurier2008-05-20
Originally committed as revision 13203 to svn://svn.ffmpeg.org/ffmpeg/trunk