summaryrefslogtreecommitdiff
path: root/libavformat/rtsp.c
Commit message (Expand)AuthorAge
* Rename RTSPHeader to RTSPMessageHeader to reflect more clearly what theRonald S. Bultje2009-02-21
* Change sizeof(struct_type) to sizeof(variable).Ronald S. Bultje2009-02-21
* Remame rtp_get_codec_info() to ff_rtp_get_codec_info(), as it is notLuca Abeni2009-02-17
* Rename RTSP_*_LAST to RTSP_*_NB in line with PIX_FMT_* in lavc. See "[PATCH]Ronald S. Bultje2009-02-16
* Split rtp.h in rtp.h, rtpdec.h, and rtpenc.hLuca Abeni2009-02-06
* Rename "tx_ctx" and "cur_tx" variables to "transport_priv" andRonald S. Bultje2009-02-05
* use new metadata API in rtsp demuxerAurelien Jacobs2009-02-02
* Fix the Transport: line in the SETUP request so that it works with WMSRonald S. Bultje2009-02-01
* Merge rtp_internal.h in rtp.h, and remove rtp_internal.hLuca Abeni2009-01-27
* Skip m= blocks in the SDP if the media type is unknown. This preventsRonald S. Bultje2009-01-24
* cosmetics: Remove pointless period after copyright statement non-sentences.Diego Biurrun2009-01-19
* Change semantic of CONFIG_*, HAVE_* and ARCH_*.Aurelien Jacobs2009-01-13
* Fix build: Add intreadwrite.h and bswap.h #includes where necessary.Diego Biurrun2009-01-11
* Reindent to properly fit a 80 chars terminal.Ronald S. Bultje2009-01-09
* Reindent after r16509.Ronald S. Bultje2009-01-09
* Apply rtpmap: SDP lines to the last m= line only, since they generally justRonald S. Bultje2009-01-09
* Increase buffer size for RTP packet data because some ASF streams use aRonald S. Bultje2009-01-09
* Use the "server" RTSP field to detect whether the server that we're talkingRonald S. Bultje2009-01-07
* Export RTSPState and RTSPStream from rtsp.c into rtsp.h. This allows futureRonald S. Bultje2009-01-07
* Allow subscription to any of the streams, not just the first, available inRonald S. Bultje2009-01-07
* Parse the OpaqueData field for every AVStream represented by this "set ofRonald S. Bultje2009-01-07
* Parse the ASMRuleBook SDP line to dynamically create one new AVStream forRonald S. Bultje2009-01-07
* Add comment to indicate why the SDP line buffer is as big as it is.Ronald S. Bultje2008-12-14
* Increase SDP line buffer size because ASF headers in RTSP-MS are very big. Se...Ronald S. Bultje2008-12-14
* Rename rtp_payload_data_t to avoid clashes with the POSIX namespaceLuca Abeni2008-12-13
* Rename type to be consistentLuca Barbato2008-12-13
* Change function prototype of the sdp_parse_a_line in DynamicProtocolHandler.Ronald S. Bultje2008-12-06
* Change function prototype from taking an AVStream to taking an index to theRonald S. Bultje2008-11-30
* Add is_keyframe param to ff_rdt_parse_header(). See ML discussion inRonald S. Bultje2008-11-15
* Call check_back_and_send_rr() function only in case of RTP as a transport.Ronald S. Bultje2008-11-15
* Reindent after r15544.Ronald S. Bultje2008-10-04
* Implement RDTDemuxContext, which contains RDT-specific data (similar toRonald S. Bultje2008-10-04
* Make RTPDemuxContext opaque in rtsp.c, renaming it to tx_ctx (tx=transport)Ronald S. Bultje2008-10-04
* Remove access into RTPDemuxContext in rtsp.c, which allows making it opaqueRonald S. Bultje2008-10-04
* Rename RTP payload contexts to PayloadContext, suggested by Luca inRonald S. Bultje2008-10-04
* Use enum typers instead of int.Diego Pettenò2008-10-02
* Add (additional) const to many global tables.Reimar Döffinger2008-10-02
* This patch refactors RDT packet header parsing so that it can be used inRonald S. Bultje2008-10-01
* Reindent after previous patches.Ronald S. Bultje2008-09-30
* Implement a RTSPTransport field, which allows proper separation of serverRonald S. Bultje2008-09-30
* Remove access to rdt_data struct in functions called outside of theRonald S. Bultje2008-09-30
* Send improper UDP SETUP request, which is what Realmedia servers expect.Ronald S. Bultje2008-09-30
* Rename RTSPProtocol to RTSPLowerTransport, so that its name properly tells usRonald S. Bultje2008-09-30
* only include sys/select.h if present, fix mingw compilationBaptiste Coudurier2008-09-26
* include sys/select.h instead of unistd.h to get select,Baptiste Coudurier2008-09-24
* Reindent after r15317.Ronald S. Bultje2008-09-14
* Rename RTSP_SERVER_RDT to RTSP_SERVER_REAL, because RDT (the transportRonald S. Bultje2008-09-14
* Reindent after r15927, see discussion in "[PATCH] rtsp cleanup part 1:Ronald S. Bultje2008-09-11
* Factorize out common code for opening of the RTP parsing context betweenRonald S. Bultje2008-09-11
* Implement RDT-specific data parsing routines. After these changes, simpleRonald S. Bultje2008-09-07