summaryrefslogtreecommitdiff
path: root/libavformat/rtpdec_vp8.c
Commit message (Collapse)AuthorAge
* cosmetics: Fix spelling mistakesVittorio Giovara2016-05-04
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* rtpdec: Rename the free method to closeMartin Storsjö2015-02-24
| | | | | | | | | Many of these functions were named foo_free_context, and since the functions no longer should free the context itself, only allocated elements within it, the previous naming was slightly misleading. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: Use ffio_free_dyn_bufMartin Storsjö2015-02-24
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: Don't free the payload context in the .free functionMartin Storsjö2015-02-24
| | | | | | | | | | | | | | This makes it more consistent with depacketizers that don't have any .free function at all, where the payload context is freed by the surrounding framework. Always free the context in the surrounding framework, having the individual depacketizers only free any data they've specifically allocated themselves. This is similar to how this works for demuxer/muxers/codecs - a component shouldn't free the priv_data that the framework has allocated for it. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: Use .init instead of .alloc to set default valuesMartin Storsjö2015-02-24
| | | | | | The ugly error handling in rdt gets improved in a later commit. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Set the keyframe flagMartin Storsjö2015-02-20
| | | | | | | This allows the output to be used with stream copy, which discards packet from the start until the first keyframe. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: Initialize some variables to silence compiler warningsMartin Storsjö2013-03-02
| | | | | | | | The warnings are false positives, older gcc versions (such as 4.5) think the variables can be used uninitialized while they in practice can't, while newer (4.6) gets it right. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Don't trim too much data from broken framesMartin Storsjö2013-01-10
| | | | | | | | | | | | | Previously, for broken frames, we only returned the first partition of the frame (we would append all the received packets to the packet buffer, then set pkt->size to the size of the first partition, since the rest of the frame could have lost data inbetween) - now instead return the full buffered data we have, but don't append anything more to the buffer after the lost packet discontinuity. Decoding the truncated packet should hopefully get better quality than trimming out everything after the first partition. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Simplify code by using an existing helper functionMartin Storsjö2013-01-10
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Mark broken packets with AV_PKT_FLAG_CORRUPTMartin Storsjö2013-01-09
| | | | | | | | This allows the caller to either include them (and get more packets decoded, but possibly some nonperfect frames), or discard them (by setting fflags=discardcorrupt). Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Request a keyframe if RTP packets are lostMartin Storsjö2013-01-08
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Avoid a warning about a possibly unused variableMartin Storsjö2013-01-08
| | | | | | | | The warning is a false positive, but I prefer actually initializing it over masking it with av_uninit, since the code is not performance critical. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Make sure the previous packet is returnedMartin Storsjö2013-01-08
| | | | | | | | | | | This is a bug from c7d4de3d73 - if the previous frame wasn't returned yet (due to missing the final packets), but we have enough data of it to return the first partition, we write that into pkt and set returned_old_frame. That commit forgot returning 0 for the case where this current packet didn't have the end_packet flag set. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Set the timestamp when returning a deferred packetMartin Storsjö2013-01-08
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Don't return known-broken packetsMartin Storsjö2012-12-21
| | | | | | | | | | | | | | | | This is built on the assumption that the first partition of each VP8 packet is essential for decoding any later packet - if this partition is broken/missed, the arithmetic coder gets out of sync and decoding the bitstream in further packet ends up with total garbage. If packets of a frame are lost, make sure the first partition is intact (return only this part of the packet, nothing else), otherwise stop returning data until the next keyframe is received. Alternatively, one would simply not return any packets at all until the next keyframe, if packet loss is detected. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: Pass the sequence number to depacketizersMartin Storsjö2012-12-21
| | | | | | This allows depacketizers to figure out if packets have been lost. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Cosmetics: Fix bad alignment/indentationMartin Storsjö2012-12-16
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec_vp8: Don't parse fields that aren't usedMartin Storsjö2012-11-02
| | | | | | This avoids warnings about unused variables. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtpdec: factorize identical code used in several handlersAnton Khirnov2012-11-02
|
* rtpdec_vp8: Make the depacketizer implement the latest spec draftMartin Storsjö2012-10-08
| | | | | | | | | | | Not all details are implemented, but it's enough for proper playback as long as there is no packet loss. Tested to work with the packetizer in gstreamer (which although uses a different codec name, to clarify that it is still a spec draft). Signed-off-by: Martin Storsjö <martin@martin.st>
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* doxygen: use Doxygen markup for authors and web links where appropriateDiego Biurrun2011-07-15
|
* rtp: Rename the open/close functions to alloc/freeMartin Storsjö2011-04-24
| | | | | | | This avoids clashes if we internally want to override the global open function. Signed-off-by: Martin Storsjö <martin@martin.st>
* avio: avio_ prefix for url_close_dyn_bufAnton Khirnov2011-04-03
|
* avio: avio_ prefix for url_open_dyn_bufAnton Khirnov2011-04-03
|
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* avio: avio: avio_ prefixes for put_* functionsAnton Khirnov2011-02-21
| | | | | | | | | | | | In the name of consistency: put_byte -> avio_w8 put_<type> -> avio_w<type> put_buffer -> avio_write put_nbyte will be made private put_tag will be merged with avio_put_str Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: rename ByteIOContext to AVIOContext.Anton Khirnov2011-02-20
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* RTP/VP8: Update the warning about the VP8 payloadMartin Storsjö2010-12-05
| | | | | | | The current implementation is incompatible with the latest spec drafts, this should be communicated clearly to the user. Originally committed as revision 25887 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add RTP depacketization of VP8Josh Allmann2010-08-16
Patch by Josh Allmann, joshua dot allmann at gmail Originally committed as revision 24798 to svn://svn.ffmpeg.org/ffmpeg/trunk