summaryrefslogtreecommitdiff
path: root/libavformat/rtp.h
Commit message (Collapse)AuthorAge
* lavf: replace AVStream.codec with AVStream.codecparAnton Khirnov2016-02-23
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, AVStream contains an embedded AVCodecContext instance, which is used by demuxers to export stream parameters to the caller and by muxers to receive stream parameters from the caller. It is also used internally as the codec context that is passed to parsers. In addition, it is also widely used by the callers as the decoding (when demuxer) or encoding (when muxing) context, though this has been officially discouraged since Libav 11. There are multiple important problems with this approach: - the fields in AVCodecContext are in general one of * stream parameters * codec options * codec state However, it's not clear which ones are which. It is consequently unclear which fields are a demuxer allowed to set or a muxer allowed to read. This leads to erratic behaviour depending on whether decoding or encoding is being performed or not (and whether it uses the AVStream embedded codec context). - various synchronization issues arising from the fact that the same context is used by several different APIs (muxers/demuxers, parsers, bitstream filters and encoders/decoders) simultaneously, with there being no clear rules for who can modify what and the different processes being typically delayed with respect to each other. - avformat_find_stream_info() making it necessary to support opening and closing a single codec context multiple times, thus complicating the semantics of freeing various allocated objects in the codec context. Those problems are resolved by replacing the AVStream embedded codec context with a newly added AVCodecParameters instance, which stores only the stream parameters exported by the demuxers or read by the muxers.
* rtpenc: Simplify code by introducing a macro for rescaling NTP timestampsMartin Storsjö2013-07-31
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* rtp: set the payload type as stream idLuca Barbato2012-11-14
| | | | | | | Support multiple video/audio streams with different format in the same session. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* rtp: Update the check for distinguishing between RTP and RTCPMartin Storsjö2012-10-18
| | | | | | | Also add enums for more RTCP packet types, according to the IANA list of registered types. Signed-off-by: Martin Storsjö <martin@martin.st>
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* misc typo and wording fixesDiego Biurrun2012-07-03
|
* rtp: Factorize the check for distinguishing RTCP packets from RTPMartin Storsjö2012-02-16
| | | | | | The binary doesn't change after this patch. Signed-off-by: Martin Storsjö <martin@martin.st>
* Fix a bunch of common typos.Diego Biurrun2011-12-11
|
* rtpenc: Add a payload type private optionRafaël Carré2011-09-26
| | | | | | | | Specifying the payload type is useful when the type number has already been negotiated before creating the stream, for example in SIP protocol. Signed-off-by: Martin Storsjö <martin@martin.st>
* rtp: Correct ff_rtp_get_payload_type documentationRafaël Carré2011-09-26
| | | | | | Since 0c378ea1f, it can't fail anymore. Signed-off-by: Martin Storsjö <martin@martin.st>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* rtp: Replace hardcoded RTCP packet types with definesJosh Allmann2010-08-25
| | | | | | Patch by Josh Allmann, joshua dot allmann at gmail Originally committed as revision 24912 to svn://svn.ffmpeg.org/ffmpeg/trunk
* rtpenc_xiph: Set the ident value via a defineMartin Storsjö2010-08-09
| | | | Originally committed as revision 24749 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_codec_id()Luca Abeni2009-02-28
| | | | Originally committed as revision 17666 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix typo in a commentLuca Abeni2009-02-28
| | | | Originally committed as revision 17664 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_enc_name()Luca Abeni2009-02-28
| | | | Originally committed as revision 17663 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_get_codec_info()Luca Abeni2009-02-28
| | | | Originally committed as revision 17661 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remame rtp_get_codec_info() to ff_rtp_get_codec_info(), as it is notLuca Abeni2009-02-17
| | | | | | a static function Originally committed as revision 17390 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move to rtp.h the prototypes of all the functions defined in rtp.cLuca Abeni2009-02-17
| | | | Originally committed as revision 17389 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Document ff_rtp_get_payload_type()Luca Abeni2009-02-16
| | | | Originally committed as revision 17365 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename rtp_get_payload_type() to ff_rtp_get_payload_type(), as it is notLuca Abeni2009-02-16
| | | | | | a static function Originally committed as revision 17364 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move RTP_MAX_PACKET_LENGTH to rtpdec.h: it is not used in the muxer anymoreLuca Abeni2009-02-06
| | | | Originally committed as revision 17023 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split rtp.h in rtp.h, rtpdec.h, and rtpenc.hLuca Abeni2009-02-06
| | | | Originally committed as revision 17016 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add "AVFormatContext *ctx" (that being the RTSP demuxer's) as first argumentRonald S. Bultje2009-02-06
| | | | | | | | | | | | to the parse_packet() function pointer in RTPDynamicProtocolHandlers. This allows these functions to peek back and retrieve values from the demuxer's context (or RTSPState). The ASF/RTP payload parser will use this to be able to parse SDP values (which occur even before the payload ID is given), store them in the RTSPState and then retrieve them while parsing payload data. See "[PATCH] RTSP-MS 13/15: add RTSP demuxer AVFormatContext to parse_packet() function pointer (was: transport context)" mailinglist thread. Originally committed as revision 17015 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Introduce a new num_frames field in RTPDemuxContext so that rtp_aac.cLuca Abeni2009-02-05
| | | | | | does not need to abuse read_buf_index Originally committed as revision 17004 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Merge rtp_internal.h in rtp.h, and remove rtp_internal.hLuca Abeni2009-01-27
| | | | Originally committed as revision 16817 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics: Remove pointless period after copyright statement non-sentences.Diego Biurrun2009-01-19
| | | | Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename rtp_payload_data_t to avoid clashes with the POSIX namespaceLuca Abeni2008-12-13
| | | | Originally committed as revision 16115 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove useless typedefLuca Abeni2008-12-13
| | | | Originally committed as revision 16114 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove unused typesLuca Abeni2008-12-13
| | | | Originally committed as revision 16113 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove access into RTPDemuxContext in rtsp.c, which allows making it opaqueRonald S. Bultje2008-10-04
| | | | | | | (and thus preparing for the introduction of RDTDemuxContext) in a next patch. See discussion in "RDT/Realmedia patches #2" thread on ML. Originally committed as revision 15542 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Globally rename the header inclusion guard names.Stefano Sabatini2008-08-31
| | | | | | | | | Consistently apply this rule: the guard name is obtained from the filename by stripping the leading "lib", converting '/' and '.' to '_' and uppercasing the resulting name. Guard names in the root directory have to be prefixed by "FFMPEG_". Originally committed as revision 15120 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Revert r14497Michael Niedermayer2008-08-01
| | | | | | | | | Log: Add missing header #includes. Policy violation (change not approved by maintainer) and while discussions where ongoing and no consensus has been reached. Originally committed as revision 14500 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing header #includes.Diego Biurrun2008-08-01
| | | | Originally committed as revision 14497 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use full path for #includes from another directory.Diego Biurrun2008-05-09
| | | | Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make AVRtpPayloadTypes static and constantDiego Pettenò2008-01-06
| | | | | | Patch by Diego 'Flameeyes' Pettenò (flameeyes AT gmail DOT com) Originally committed as revision 11432 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove prototype for non-existent functionLuca Abeni2007-10-26
| | | | Originally committed as revision 10862 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add FFMPEG_ prefix to all multiple inclusion guards.Diego Biurrun2007-10-17
| | | | Originally committed as revision 10765 to svn://svn.ffmpeg.org/ffmpeg/trunk
* rtp and rtsp demuxer declarations are not part of public APIAurelien Jacobs2007-09-10
| | | | Originally committed as revision 10474 to svn://svn.ffmpeg.org/ffmpeg/trunk
* *_protocol are not part of public APIAurelien Jacobs2007-09-10
| | | | Originally committed as revision 10472 to svn://svn.ffmpeg.org/ffmpeg/trunk
* include all prerequisites in header filesMåns Rullgård2007-06-16
| | | | Originally committed as revision 9344 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Doxygenize the unaltered comments for the AUHeaders structure.Panagiotis Issaris2007-03-05
| | | | Originally committed as revision 8249 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Doxygenize the unaltered comments for the rtp_payload_data_s struct.Panagiotis Issaris2007-03-05
| | | | Originally committed as revision 8248 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Doxygenize the unaltered comments for the RTP_MAX_SDES definition.Panagiotis Issaris2007-03-05
| | | | Originally committed as revision 8247 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Doxygenize the existing comments without altering the actual contents of thePanagiotis Issaris2007-03-05
| | | | | | comment. Originally committed as revision 8246 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move rtp_check_and_send_back_rr()'s unaltered comments to the header file.Panagiotis Issaris2007-03-04
| | | | Originally committed as revision 8234 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move rtp_get_payload_type()'s unaltered comments to the header file.Panagiotis Issaris2007-03-04
| | | | Originally committed as revision 8233 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics: fix usefuLL --> usefuL typoDiego Biurrun2007-02-22
| | | | Originally committed as revision 8061 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Missing prototype addedLuca Barbato2007-01-29
| | | | Originally committed as revision 7760 to svn://svn.ffmpeg.org/ffmpeg/trunk