summaryrefslogtreecommitdiff
path: root/libavformat/amr.c
Commit message (Collapse)AuthorAge
* cosmetics: Fix spelling mistakesVittorio Giovara2016-05-04
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* lavf: replace AVStream.codec with AVStream.codecparAnton Khirnov2016-02-23
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Currently, AVStream contains an embedded AVCodecContext instance, which is used by demuxers to export stream parameters to the caller and by muxers to receive stream parameters from the caller. It is also used internally as the codec context that is passed to parsers. In addition, it is also widely used by the callers as the decoding (when demuxer) or encoding (when muxing) context, though this has been officially discouraged since Libav 11. There are multiple important problems with this approach: - the fields in AVCodecContext are in general one of * stream parameters * codec options * codec state However, it's not clear which ones are which. It is consequently unclear which fields are a demuxer allowed to set or a muxer allowed to read. This leads to erratic behaviour depending on whether decoding or encoding is being performed or not (and whether it uses the AVStream embedded codec context). - various synchronization issues arising from the fact that the same context is used by several different APIs (muxers/demuxers, parsers, bitstream filters and encoders/decoders) simultaneously, with there being no clear rules for who can modify what and the different processes being typically delayed with respect to each other. - avformat_find_stream_info() making it necessary to support opening and closing a single codec context multiple times, thus complicating the semantics of freeing various allocated objects in the codec context. Those problems are resolved by replacing the AVStream embedded codec context with a newly added AVCodecParameters instance, which stores only the stream parameters exported by the demuxers or read by the muxers.
* avpacket: Replace av_free_packet with av_packet_unrefLuca Barbato2015-10-26
| | | | | | | `av_packet_unref` matches the AVFrame ref-counted API and can be used as a drop in replacement. Deprecate `av_free_packet`.
* lavf: add the notimestamps flag to the muxers missing itAnton Khirnov2014-06-18
|
* lavf: Don't explicitly flush after each written packet in muxersClément Bœsch2013-09-16
| | | | | | | | Since 596e5d4783, this is not necessary anymore. It also allows to actually disable the flushing, improving write performance (but possibly giving worse latency in real-time streaming). Signed-off-by: Martin Storsjö <martin@martin.st>
* amr: set channel_layoutJustin Ruggles2012-11-12
|
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* avformat: Drop pointless "format" from container long namesDiego Biurrun2012-07-30
|
* amr: Mark an array constMartin Storsjö2012-06-17
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* amr: More space cleanupMartin Storsjö2012-06-17
| | | | | | This was missed in the previous cleanup patch. Signed-off-by: Martin Storsjö <martin@martin.st>
* amr: Cosmetic cleanupMartin Storsjö2012-06-17
| | | | | | | | Add spaces around operators, fix brace placement and whitespace to match K&R style, vertically align code, remove redundant != 0 and convert x == 0 into !x, drop useless braces. Signed-off-by: Martin Storsjö <martin@martin.st>
* cosmetics: Align muxer/demuxer declarationsMartin Storsjö2012-04-06
| | | | | | | Also add missing trailing commas, break long codec_tag lines and add spaces in codec_tag declarations. Signed-off-by: Martin Storsjö <martin@martin.st>
* amr demuxer: do not set AVCodecContext.frame_size.Justin Ruggles2012-03-05
| | | | it is not necessary.
* lavf: remove AVFormatParameters from AVFormatContext.read_header signatureAnton Khirnov2012-01-27
|
* lavf: make av_set_pts_info private.Anton Khirnov2011-11-30
| | | | It's supposed to be called only from (de)muxers.
* Eliminate pointless 0/NULL initializers in AVCodec and similar declarations.Diego Biurrun2011-11-28
|
* lavf,lavd: replace av_new_stream->avformat_new_stream part I.Anton Khirnov2011-10-19
| | | | | Trivial replacements with sed are done in this commit: sed 's/av_new_stream(\([^)]*\), 0)/avformat_new_stream(\1, NULL)/'
* lavf: use designated initialisers for all (de)muxers.Anton Khirnov2011-07-17
| | | | It's more readable and less prone to breakage.
* amr: Set the AVFMT_GENERIC_INDEX flagMartin Storsjö2011-03-21
| | | | | This makes the amr demuxer support seeking, closing roundup issue 2593.
* amr: Set the pkt->pos field properly to the start of the packetMartin Storsjö2011-03-21
| | | | | Previously, the field pointed to the second byte of the packet (which is the first byte of the actual AMR payload).
* amr: Set the codec->bit_rate field based on the last packetMartin Storsjö2011-03-21
| | | | | | | | This allows libavformat to guess an estimated duration for amr files. For streams with varying bit rates (or with silence descriptors or "no frame" blocks) the guess is, of course, inaccurate.
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* avio: rename put_flush_packet -> avio_flushAnton Khirnov2011-03-16
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: deprecate url_feofAnton Khirnov2011-03-07
| | | | | | AVIOContext.eof_reached should be used directly instead. Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: add avio_tell macro as a replacement for url_ftellAnton Khirnov2011-03-04
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* lavf: replace remaining uses of put_tag with avio_writeAnton Khirnov2011-02-25
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: avio: avio_ prefixes for put_* functionsAnton Khirnov2011-02-21
| | | | | | | | | | | | In the name of consistency: put_byte -> avio_w8 put_<type> -> avio_w<type> put_buffer -> avio_write put_nbyte will be made private put_tag will be merged with avio_put_str Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: avio_ prefixes for get_* functionsAnton Khirnov2011-02-21
| | | | | | | | | | | | | | In the name of consistency: get_byte -> avio_r8 get_<type> -> avio_r<type> get_buffer -> avio_read get_partial_buffer will be made private later get_strz is left out becase I want to change it later to return something useful. Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* avio: rename ByteIOContext to AVIOContext.Anton Khirnov2011-02-20
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.Diego Elio Pettenò2011-01-26
| | | | | This also lists the objects from those two libraries as internal (by adding the ff_ prefix) so that they can then be hidden via linker scripts.
* Set frame_size in the amr demuxerMartin Storsjö2010-09-03
| | | | Originally committed as revision 25030 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change semantic of CONFIG_*, HAVE_* and ARCH_*.Aurelien Jacobs2009-01-13
| | | | | | They are now always defined to either 0 or 1. Originally committed as revision 16590 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Replace generic CONFIG_MUXERS preprocessor conditionals by more specificDiego Biurrun2008-09-02
| | | | | | CONFIG_FOO_MUXER conditionals where appropriate. Originally committed as revision 15158 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.Stefano Sabatini2008-06-03
| | | | | | | patch by Stefano Sabatini, stefano.sabatini-lala poste.it along with some spelling/consistency fixes for the long names by me Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use dynamically allocated ByteIOContext in AVFormatContextBjörn Axelsson2007-11-21
| | | | | | | patch by: Björn Axelsson, bjorn d axelsson a intinor d se thread: [PATCH] Remove static ByteIOContexts, 06 nov 2007 Originally committed as revision 11071 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Replace all occurrences of AVERROR_IO with AVERROR(EIO).Panagiotis Issaris2007-07-19
| | | | Originally committed as revision 9760 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Replace all occurrences of AVERROR_NOMEM with AVERROR(ENOMEM).Panagiotis Issaris2007-07-19
| | | | Originally committed as revision 9759 to svn://svn.ffmpeg.org/ffmpeg/trunk
* kill uninitialised variable warning in amr_read_packet()Måns Rullgård2007-07-07
| | | | Originally committed as revision 9522 to svn://svn.ffmpeg.org/ffmpeg/trunk
* remove empty write trailer functionsVitor Sessak2007-06-27
| | | | | | patch by Vitor: [vitor1001 gmail com] Originally committed as revision 9442 to svn://svn.ffmpeg.org/ffmpeg/trunk
* allocate 32 extra bytes at the end of the probe buffer and remove most probe ↵Michael Niedermayer2007-04-08
| | | | | | buf_size checks Originally committed as revision 8677 to svn://svn.ffmpeg.org/ffmpeg/trunk
* unused #defineMichael Niedermayer2006-10-10
| | | | Originally committed as revision 6638 to svn://svn.ffmpeg.org/ffmpeg/trunk
* remove dummy amr_read_close()Michael Niedermayer2006-10-10
| | | | Originally committed as revision 6637 to svn://svn.ffmpeg.org/ffmpeg/trunk
* more factoriztaion and a FIXME noteMichael Niedermayer2006-10-10
| | | | Originally committed as revision 6636 to svn://svn.ffmpeg.org/ffmpeg/trunk
* factorze another 2 linesMichael Niedermayer2006-10-10
| | | | Originally committed as revision 6635 to svn://svn.ffmpeg.org/ffmpeg/trunk
* set duration and timebase (based on a patch by Simon Morlat simon.morlat ↵Michael Niedermayer2006-10-10
| | | | | | linphone org) Originally committed as revision 6634 to svn://svn.ffmpeg.org/ffmpeg/trunk
* factorize (untested)Michael Niedermayer2006-10-10
| | | | Originally committed as revision 6633 to svn://svn.ffmpeg.org/ffmpeg/trunk
* return cleanupMichael Niedermayer2006-10-10
| | | | Originally committed as revision 6632 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change license headers to say 'FFmpeg' instead of 'this program/this library'Diego Biurrun2006-10-07
| | | | | | and fix GPL/LGPL version mismatches. Originally committed as revision 6577 to svn://svn.ffmpeg.org/ffmpeg/trunk
* fix some signedness warningsMåns Rullgård2006-09-27
| | | | Originally committed as revision 6355 to svn://svn.ffmpeg.org/ffmpeg/trunk