summaryrefslogtreecommitdiff
path: root/libavfilter/vf_vflip.c
Commit message (Collapse)AuthorAge
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: check all ff_get_video_buffer() calls for errors.Anton Khirnov2012-07-22
|
* lavfi: check all avfilter_ref_buffer() calls for errors.Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: make avfilter_get_video_buffer() private on next bump.Anton Khirnov2012-06-13
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove avfilter_default_* from public API on next bump.Anton Khirnov2012-05-22
| | | | | Those functions are only useful inside filters. It is better to not support user filters until the API is more stable.
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Support filters and decoders that dont support negative linesizes.Michael Niedermayer2010-12-27
| | | | | | This patch is based on work by stefano. Originally committed as revision 26108 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Revert commit r22596.Stefano Sabatini2010-12-19
| | | | | | | | | | | | | | | | | commit ab8610aa176c13b5e25a2d8770df28a14665e169 Author: koorogi <koorogi@9553f0bf-9b14-0410-a0b8-cfaf0461ba5b> Date: Thu Mar 18 23:13:04 2010 +0000 The vflip filter does not need to keep ownership of a picture reference. Avoid creating and releasing useless extra picture references in the start_frame and end_frame callbacks. Originally committed as revision 22596 to svn://svn.ffmpeg.org/ffmpeg/trunk The new reference creation is required when the linesizes are used by the previous filters in the filterchain, for example as in "pad=W:H:X:Y,vflip". Originally committed as revision 26059 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename AVFilterPicRef to AVFilterBufferRef.S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | The struct is going to be used for storing audio buffer references as well, and the new name is more generic. Patch by S.N. Hemanth Meenakshisundaram @smeenaks@ucsd@edu@. Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* The vflip filter does not need to keep ownership of a picture reference.Bobby Bingham2010-03-18
| | | | | | | Avoid creating and releasing useless extra picture references in the start_frame and end_frame callbacks. Originally committed as revision 22596 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Avoid usage of avcodec_get_pix_fmt_name() andStefano Sabatini2010-01-31
| | | | | | | | | avcodec_get_chroma_sub_sample(), directly access av_pix_fmt_descriptors instead. Remove some of the dependancies of lavfi on lavc. Originally committed as revision 21575 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix alpha plane flipping for the yuva420p and similar pixel formats.Stefano Sabatini2009-12-08
| | | | Originally committed as revision 20771 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add a slice_dir parameter to avfilter_draw_slice().Stefano Sabatini2009-12-04
| | | | | | | | | | Avoid the need to implement slice direction detection code, thus reducing code duplication. See the thread: "[FFmpeg-devel] [PATCH] Add a slice_dir parameter to avfilter_start_frame()". Originally committed as revision 20734 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add descriptions for the committed filters.Stefano Sabatini2009-10-27
| | | | Originally committed as revision 20375 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add video vertical flip filter.Stefano Sabatini2009-10-22
Originally committed as revision 20352 to svn://svn.ffmpeg.org/ffmpeg/trunk