summaryrefslogtreecommitdiff
path: root/libavfilter/vf_unsharp.c
Commit message (Collapse)AuthorAge
* lavfi: Use AV_CEIL_RSHIFT where neededVittorio Giovara2016-01-25
|
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* lavfi: remove now unused args parameter from AVFilter.initAnton Khirnov2013-04-09
|
* vf_unsharp: switch to an AVOptions-based system.Anton Khirnov2013-04-09
|
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* lavfi: add error handling to end_frame().Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: unref AVFilterLink.out_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* lavfi: unref AVFilterLink.cur_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* lavfi: make filters less verbose.Anton Khirnov2012-06-26
|
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* vf_unsharp: Mark readonly variable as const.Diego Biurrun2012-04-04
| | | | | This fixes the following warning: libavfilter/vf_unsharp.c:106: warning: initialization discards qualifiers from pointer target type
* vf_unsharp: set default chroma size value to 5x5Stefano Sabatini2011-09-29
| | | | | | | The previous default value 0x0 was not good, since it is not even valid. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vf_unsharp: fix out-of-buffer readStefano Sabatini2011-09-29
| | | | | | | | | | | | In apply_unsharp(), when y is >= height, prevent out-of-buffer reading from src, read from the last buffer line in src2 instead. The check was implemented in the original unsharp libmpcodecs code and lost in the port. This also fixes output discrepancy between the two filters. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vf_unsharp: store hsub/vsub in the filter contextStefano Sabatini2011-09-28
| | | | | | Also drop obfuscating CHROMA_WIDTH/HEIGHT macros. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vf_unsharp: adopt a more natural order of params in apply_unsharp()Stefano Sabatini2011-09-28
| | | | Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vf_unsharp: rename method "unsharpen" to "apply_unsharp"Stefano Sabatini2011-09-28
| | | | | | | More consistent with the original libmpcodecs code, and the name "unsharpen" was confusing. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make the validity checks fail only if the corresponding luma or chromaStefano Sabatini2010-10-13
| | | | | | | values are not zero. Prevent aborting with the default values. Originally committed as revision 25471 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add validity checks for the unsharp filter.Stefano Sabatini2010-10-08
| | | | | | Prevent crash. Originally committed as revision 25419 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename fields:S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | | | | | | AVFilterLink.srcpic -> AVFilterLink.src_buf AVFilterLink.cur_pic -> AVFilterLink.cur_buf AVFilterLink.outpic -> AVFilterLink.out_buf The new names are more generic and more consistent, since the struct they contain, which was named AVFilterPicRef, has been renamed to AVFilterBufferRef. Patch by S.N. Hemanth Meenakshisundaram %smeenaks%ucsd%edu%. Originally committed as revision 24732 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename functions and fields:S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | | | | avfilter_(un)ref_pic -> avfilter_(un)ref_buffer avfilter_copy_picref_props -> avfilter_copy_buffer_ref_props AVFilterBufferRef.pic -> AVFilterBufferRef.buffer They have been renamed to allow sharing with audio. Patch by S.N. Hemanth Meenakshisundaram $smeenaks$ucsd$edu$. Originally committed as revision 24731 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename AVFilterPicRef to AVFilterBufferRef.S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | The struct is going to be used for storing audio buffer references as well, and the new name is more generic. Patch by S.N. Hemanth Meenakshisundaram @smeenaks@ucsd@edu@. Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix clang warning, make initialization more readableEli Friedman2010-06-27
| | | | | | Patch by Eli Friedman, eli dot friedman at gmail Originally committed as revision 23829 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add unsharp video filter.Bobby Bingham2010-04-07
Contributed by Daniel G. Taylor (dan/at/programmer-art/dot/org) Originally committed as revision 22813 to svn://svn.ffmpeg.org/ffmpeg/trunk