summaryrefslogtreecommitdiff
path: root/libavfilter/vf_slicify.c
Commit message (Collapse)AuthorAge
* lavfi: remove vf_slicifyAnton Khirnov2012-11-28
| | | | | | | The following commit will make it useless. The crop_scale_vflip FATE test changes because of off-by-one differences in output when vflipped slices are passed to sws.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* vf_slicify: clear AVFilterLink.cur_buf in start_frame().Anton Khirnov2012-07-20
| | | | | The buffer is passed on to the next filter, so we shouldn't keep any pointers to it.
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove avfilter_null_* from public API on next bump.Anton Khirnov2012-05-22
| | | | | Those functions are only useful inside filters. It is better to not support user filters until the API is more stable.
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing uses of NULL_IF_CONFIG_SMALL for the filters descriptions.Stefano Sabatini2010-09-24
| | | | Originally committed as revision 25182 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename AVFilterPicRef to AVFilterBufferRef.S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | The struct is going to be used for storing audio buffer references as well, and the new name is more generic. Patch by S.N. Hemanth Meenakshisundaram @smeenaks@ucsd@edu@. Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use the new null callbacks to simplify filters and reduce duplicated code.Bobby Bingham2010-03-18
| | | | Originally committed as revision 22595 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Extend the slice filter to make it issue slice height values randomlyStefano Sabatini2010-03-13
| | | | | | | | | | | | | | choosen between 8 and 32 when the supplied parameter is the string "random". This is useful for testing the slice support, but it is not supposed to be used for other purposes and this interface may change in the future, thus it is not documented. The randomization algorithm adopted is the standard Numerical Recipes LCG. Originally committed as revision 22505 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Avoid usage of avcodec_get_pix_fmt_name() andStefano Sabatini2010-01-31
| | | | | | | | | avcodec_get_chroma_sub_sample(), directly access av_pix_fmt_descriptors instead. Remove some of the dependancies of lavfi on lavc. Originally committed as revision 21575 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reindent after the last commit.Stefano Sabatini2009-12-06
| | | | Originally committed as revision 20755 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix slicify when the slice_direction is negative, make it send slicesStefano Sabatini2009-12-06
| | | | | | from the bottom to the top one. Originally committed as revision 20754 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add a slice_dir parameter to avfilter_draw_slice().Stefano Sabatini2009-12-04
| | | | | | | | | | Avoid the need to implement slice direction detection code, thus reducing code duplication. See the thread: "[FFmpeg-devel] [PATCH] Add a slice_dir parameter to avfilter_start_frame()". Originally committed as revision 20734 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add slicify video filter.Stefano Sabatini2009-11-03
Originally committed as revision 20445 to svn://svn.ffmpeg.org/ffmpeg/trunk