summaryrefslogtreecommitdiff
path: root/libavfilter/vf_pixdesctest.c
Commit message (Collapse)AuthorAge
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* vf_pixdesctest: make config_props work properly when called multiple times.Anton Khirnov2013-05-17
|
* pixdesc: rename PIX_FMT_* flags to AV_PIX_FMT_FLAG_*Anton Khirnov2013-05-15
|
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: check all avfilter_ref_buffer() calls for errors.Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: make avfilter_get_video_buffer() private on next bump.Anton Khirnov2012-06-13
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* pixdesc: mark pseudopaletted formats with a special flag.Anton Khirnov2012-02-08
| | | | | | This makes it possible to dintinguish them from PAL8. Fixes an invalid write in avpicture_layout().
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing uses of NULL_IF_CONFIG_SMALL for the filters descriptions.Stefano Sabatini2010-09-24
| | | | Originally committed as revision 25182 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename fields:S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | | | | | | AVFilterLink.srcpic -> AVFilterLink.src_buf AVFilterLink.cur_pic -> AVFilterLink.cur_buf AVFilterLink.outpic -> AVFilterLink.out_buf The new names are more generic and more consistent, since the struct they contain, which was named AVFilterPicRef, has been renamed to AVFilterBufferRef. Patch by S.N. Hemanth Meenakshisundaram %smeenaks%ucsd%edu%. Originally committed as revision 24732 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename functions and fields:S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | | | | avfilter_(un)ref_pic -> avfilter_(un)ref_buffer avfilter_copy_picref_props -> avfilter_copy_buffer_ref_props AVFilterBufferRef.pic -> AVFilterBufferRef.buffer They have been renamed to allow sharing with audio. Patch by S.N. Hemanth Meenakshisundaram $smeenaks$ucsd$edu$. Originally committed as revision 24731 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename AVFilterPicRef to AVFilterBufferRef.S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | The struct is going to be used for storing audio buffer references as well, and the new name is more generic. Patch by S.N. Hemanth Meenakshisundaram @smeenaks@ucsd@edu@. Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reindent after r24101.Stefano Sabatini2010-07-08
| | | | Originally committed as revision 24126 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename read/write_line() to av_read/write_image_line().Stefano Sabatini2010-07-07
| | | | | | | | | The old names were not av_ prefixed, and they were causing linking failure on many platforms. The new names are also more descriptive. Patch by Stefano Sabatini. Originally committed as revision 24101 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add pixdesctest filter and corresponding test.Stefano Sabatini2010-07-07
Originally committed as revision 24092 to svn://svn.ffmpeg.org/ffmpeg/trunk