summaryrefslogtreecommitdiff
path: root/libavfilter/vf_pad.c
Commit message (Collapse)AuthorAge
* Drop pointless assert.h #includesDiego Biurrun2016-05-03
|
* vf_pad: fix x, y option expression evaluationJohn Stebbins2015-11-06
| | | | | | | | Calculation of x an y based on width and height did not work when width == 0 or height == 0. "0" substitutes the input width and height, but did so too late for x, y expression evaluation. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* Revert "lavfi: always check av_expr_parse_and_eval() return value"Anton Khirnov2015-05-05
| | | | | | | This reverts commit 63be97ec403023fb664798432acedaf6e6922527. All those calls were unchecked on purpose, as explained in the comments in the code.
* lavfi: always check av_expr_parse_and_eval() return valueVittorio Giovara2014-12-18
| | | | | CC: libav-stable@libav.org Bug-Id: CID 703624
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* vf_pad: use the name 's' for the pointer to the private contextAnton Khirnov2013-05-16
| | | | This is shorter and consistent across filters.
* lavfi: remove now unused args parameter from AVFilter.initAnton Khirnov2013-04-09
|
* vf_pad: switch to an AVOptions-based system.Anton Khirnov2013-04-09
|
* vf_pad: fix a & instead of && typoXi Wang2013-03-10
| | | | | | | Avoid buffer overflow in buffer_needs_copy() Signed-off-by: Xi Wang <xi.wang@gmail.com> Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* vf_pad/scale: use double precision for aspect ratios.Anton Khirnov2012-10-06
| | | | | | Fixes Bug 203. CC:libav-stable@libav.org
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: check all ff_get_video_buffer() calls for errors.Anton Khirnov2012-07-22
|
* lavfi: add error handling to end_frame().Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: unref AVFilterLink.out_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* lavfi: unref AVFilterLink.cur_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* vf_pad: don't give up its own reference to the output buffer.Anton Khirnov2012-07-20
|
* lavfi: make filters less verbose.Anton Khirnov2012-06-26
|
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: make avfilter_get_video_buffer() private on next bump.Anton Khirnov2012-06-13
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* Mark mutable static data const where appropriate.Alex Converse2012-02-21
|
* vf_pad: fix "vsub" variable value computationStefano Sabatini2011-09-28
| | | | | | It was shifting 2 rather than 1, +10l. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* vsrc_color: add @file doxyStefano Sabatini2011-09-19
| | | | | | Also remove outdated reference to color in vf_pad.c. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Do not include mathematics.h in avutil.hMans Rullgard2011-07-03
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* pad: make the filter parametricStefano Sabatini2011-04-26
| | | | | Signed-off-by: Stefano Sabatini <stefano.sabatini-lala@poste.it> Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* lavfi: put color source in a dedicated fileStefano Sabatini2011-02-21
| | | | | | Move the color source code from vf_pad.c to vsrc_color.c. Signed-off-by: Mans Rullgard <mans@mansr.com>
* lavfi: add drawutilsStefano Sabatini2011-02-21
| | | | | | | Add drawutils.h and drawutils.c, and use them in the pad filter. The new functions are going to be shared by other filters. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* In the pad filter, log information about the input size.Stefano Sabatini2011-01-12
| | | | Originally committed as revision 26320 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix design of the pad filter.Michael Niedermayer2011-01-11
| | | | | | | | Previously the pad filter just drawed borders in the surrounding of the input without checking if this area was allocated or writeable. Now we check and allocate a new buffer if the input is unsuitable. Originally committed as revision 26315 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In pad filter, update new ref w/h in start_frame, fix chainingBaptiste Coudurier2011-01-05
| | | | Originally committed as revision 26217 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* move the av_parse_color() function from libavfilter to libavcoreAurelien Jacobs2010-11-17
| | | | Originally committed as revision 25761 to svn://svn.ffmpeg.org/ffmpeg/trunk
* 100L fix get_video_buffer in pad filter, get_video_buffer will store wrong ↵Baptiste Coudurier2010-11-17
| | | | | | values for w and h Originally committed as revision 25759 to svn://svn.ffmpeg.org/ffmpeg/trunk
* improve av_parse_color() to allow for non-null terminated color stringAurelien Jacobs2010-11-13
| | | | Originally committed as revision 25744 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Replace deprecated CODEC_TYPE_AUDIO and CODEC_TYPE_VIDEO with theStefano Sabatini2010-09-25
| | | | | | corresponding AVMEDIA_TYPE_* symbols. Originally committed as revision 25201 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use new imgutils.h API names, fix deprecation warnings.Stefano Sabatini2010-09-07
| | | | Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Separate video specific BufferRef properties into VideoProps.S.N. Hemanth Meenakshisundaram2010-08-11
| | | | | | | | | | | | Define a new struct AVFilterBufferRefVideoProps and add a type field to AVFilterBufferRef. Video specific properties in AVFilterBufferRefVideoProps are now referred to by *video pointer in AVFilterBufferRef. Patch by S.N. Hemanth Meenakshisundaram smeenaks->ucsd.edu. Originally committed as revision 24763 to svn://svn.ffmpeg.org/ffmpeg/trunk