summaryrefslogtreecommitdiff
path: root/libavfilter/vf_hflip.c
Commit message (Collapse)AuthorAge
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* vf_hflip: use the name 's' for the pointer to the private contextAnton Khirnov2013-05-16
| | | | This is shorter and consistent across filters.
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* cosmetics: Remove some unnecessary block braces.Diego Biurrun2012-01-25
|
* hflip: make the filter accept PIX_FMT_BGR48LE and PIX_FMT_BGR48BE pixel formatsPeter Ross2011-04-28
| | | | Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* Use new imgutils.h API names, fix deprecation warnings.Stefano Sabatini2010-09-07
| | | | Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().Stefano Sabatini2010-08-20
| | | | | | | | | | The plural form is preferred as it is more consistent with the other functions: av_fill_image_linesizes() av_fill_image_pointers() and looks semantically more correct as it fills an array of elements. Originally committed as revision 24851 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix braino: @flip -> @file.Stefano Sabatini2010-08-18
| | | | Originally committed as revision 24829 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement inline function av_fill_image_max_pixstep() and use it forStefano Sabatini2010-08-18
| | | | | | factorizing code. Originally committed as revision 24827 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add hflip filter.Stefano Sabatini2010-08-17
Originally committed as revision 24806 to svn://svn.ffmpeg.org/ffmpeg/trunk