summaryrefslogtreecommitdiff
path: root/libavfilter/vf_crop.c
Commit message (Collapse)AuthorAge
* Replace av_dlog with normal av_log at trace levelVittorio Giovara2015-04-19
| | | | This applies to every library where performance is not critical.
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* vf_crop: make config_props work properly when called multiple times.Anton Khirnov2013-05-17
| | | | Do not leak the x/y expressions.
* vf_crop: cosmetics, break linesAnton Khirnov2013-05-16
|
* vf_crop: use the name 's' for the pointer to the private contextAnton Khirnov2013-05-16
| | | | This is shorter and consistent across filters.
* Remove commented-out debug #define cruftDiego Biurrun2013-05-16
|
* pixdesc: rename PIX_FMT_* flags to AV_PIX_FMT_FLAG_*Anton Khirnov2013-05-15
|
* vf_crop: switch to an AVOptions-based system.Anton Khirnov2013-04-09
|
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: do not use av_pix_fmt_descriptors directly.Anton Khirnov2012-10-12
|
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: add error handling to end_frame().Anton Khirnov2012-07-22
|
* lavfi: add error handling to draw_slice().Anton Khirnov2012-07-22
|
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* lavfi: unref AVFilterLink.cur_buf in ff_end_frame().Anton Khirnov2012-07-20
| | | | | This reduces code duplication and prevents stale pointers from remaining on the link.
* lavfi: make filters less verbose.Anton Khirnov2012-06-26
|
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* lavfi: remove avfilter_null_* from public API on next bump.Anton Khirnov2012-05-22
| | | | | Those functions are only useful inside filters. It is better to not support user filters until the API is more stable.
* Mark mutable static data const where appropriate.Alex Converse2012-02-21
|
* pixdesc: mark pseudopaletted formats with a special flag.Anton Khirnov2012-02-08
| | | | | | This makes it possible to dintinguish them from PAL8. Fixes an invalid write in avpicture_layout().
* Do not include mathematics.h in avutil.hMans Rullgard2011-07-03
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* vf_crop: Replace #ifdef DEBUG + av_log() by av_dlog().Diego Biurrun2011-05-29
|
* crop: make the filter accept PIX_FMT_BGR48LE and PIX_FMT_BGR48BE pixel formatsPeter Ross2011-04-28
| | | | Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* In crop filter, update new ref w/h instead of old one, fix chainingBaptiste Coudurier2011-01-05
| | | | Originally committed as revision 26216 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In the crop filter, put under ifdef DEBUG the trace logs for theStefano Sabatini2010-12-27
| | | | | | | | evaluated crop area coordinates. Prevent debug log spamming, define the DEBUG symbol for enabling them. Originally committed as revision 26110 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* 0.123l: remove unused arguments in av_log(), fix warning.Stefano Sabatini2010-11-24
| | | | Originally committed as revision 25820 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In crop filter, reference picref after updating w/h, fix issue #2377Baptiste Coudurier2010-11-24
| | | | Originally committed as revision 25818 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add informative log message in the crop filter.Stefano Sabatini2010-11-23
| | | | Originally committed as revision 25817 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use hierarchic names convention (prefix them with av_expr) for theStefano Sabatini2010-11-08
| | | | | | | | | eval API. More grep-friendly and more consistent with the rest of the FFmpeg API. Originally committed as revision 25708 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix crop->var_values[VAR_T] computation in the crop filter.Stefano Sabatini2010-11-02
| | | | Originally committed as revision 25645 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Prefix enum var_name symbols with VAR_, to avoid conflicts with alreadyStefano Sabatini2010-09-25
| | | | | | defined symbols, in particular should fix compilation in DOS. Originally committed as revision 25194 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix memleak introduced in:Stefano Sabatini2010-09-25
| | | | | | | | r25185 | stefano | 2010-09-25 03:18:43 +0200 (Sat, 25 Sep 2010) | 1 line Make the crop filters accept parametric expressions. Originally committed as revision 25193 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make the crop filters accept parametric expressions.Stefano Sabatini2010-09-25
| | | | Originally committed as revision 25185 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change the syntax of the crop filter from x:y:w:h to w:h:x:y.Stefano Sabatini2010-09-24
| | | | | | | Slightly more intuitive and required by a pending changes for making the filter parametric. Originally committed as revision 25184 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: remove useless parentheses.Stefano Sabatini2010-09-10
| | | | Originally committed as revision 25097 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use new imgutils.h API names, fix deprecation warnings.Stefano Sabatini2010-09-07
| | | | Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().Stefano Sabatini2010-08-20
| | | | | | | | | | The plural form is preferred as it is more consistent with the other functions: av_fill_image_linesizes() av_fill_image_pointers() and looks semantically more correct as it fills an array of elements. Originally committed as revision 24851 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement inline function av_fill_image_max_pixstep() and use it forStefano Sabatini2010-08-18
| | | | | | factorizing code. Originally committed as revision 24827 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Separate video specific BufferRef properties into VideoProps.S.N. Hemanth Meenakshisundaram2010-08-11
| | | | | | | | | | | | Define a new struct AVFilterBufferRefVideoProps and add a type field to AVFilterBufferRef. Video specific properties in AVFilterBufferRefVideoProps are now referred to by *video pointer in AVFilterBufferRef. Patch by S.N. Hemanth Meenakshisundaram smeenaks->ucsd.edu. Originally committed as revision 24763 to svn://svn.ffmpeg.org/ffmpeg/trunk