summaryrefslogtreecommitdiff
path: root/libavfilter/vf_aspect.c
Commit message (Collapse)AuthorAge
* lavfi: name anonymous structsVittorio Giovara2014-04-19
|
* vf_aspect: support variables in evaluating the aspect ratiosRudolf Polzer2013-11-02
| | | | | | | Example: -vf setsar=sar="sar*9/10" Signed-off-by: Rudolf Polzer <divverent@xonotic.org> Signed-off-by: Anton Khirnov <anton@khirnov.net>
* lavfi: do not export the filters from shared objectsAnton Khirnov2013-10-28
|
* vf_setdar: make config_props work properly when called multiple times.Anton Khirnov2013-05-17
| | | | Do not overwrite the variable set through AVOptions.
* vf_aspect: use the name 's' for the pointer to the private contextAnton Khirnov2013-05-16
| | | | This is shorter and consistent across filters.
* lavfi: remove now unused args parameter from AVFilter.initAnton Khirnov2013-04-09
|
* vf_aspect: switch to an AVOptions-based system.Anton Khirnov2013-04-09
|
* lavfi: switch to AVFrame.Anton Khirnov2013-03-08
| | | | | Deprecate AVFilterBuffer/AVFilterBufferRef and everything related to it and use AVFrame instead.
* lavfi: merge start_frame/draw_slice/end_frameAnton Khirnov2012-11-28
| | | | | Any alleged performance benefits gained from the split are purely mythological and do not justify added code complexity.
* lavfi: convert input/ouput list compound literals to named objectsMans Rullgard2012-10-10
| | | | | | | A number of compilers, for example those from TI and IBM, choke on these initialisers. The current style is also quite ugly. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: add error handling to start_frame().Anton Khirnov2012-07-22
|
* lavfi: use const for AVFilterPad declarations in all filters.Ronald S. Bultje2012-07-21
|
* vf_aspect: clear AVFilterLink.cur_buf in start_frame().Anton Khirnov2012-07-20
| | | | | The buffer is passed on to the next filter, so we shouldn't keep any pointers to it.
* lavfi: make filters less verbose.Anton Khirnov2012-06-26
|
* lavfi: remove 'opaque' parameter from AVFilter.init()Anton Khirnov2012-06-26
| | | | | | It is not used in any filters currently and is inherently evil. If passing binary data to filters is required in the future, it should be done with some AVOptions-based system.
* lavfi: make AVFilterPad opaque after two major bumps.Anton Khirnov2012-06-13
| | | | It will allow adding new fields to it without ABI breaks.
* lavfi: remove request/poll and drawing functions from public API on next bumpAnton Khirnov2012-06-05
| | | | | They are only useful inside filters and we don't allow user filters for now.
* lavfi: remove avfilter_null_* from public API on next bump.Anton Khirnov2012-05-22
| | | | | Those functions are only useful inside filters. It is better to not support user filters until the API is more stable.
* cosmetics: Remove extra newlines at EOFAlex Converse2012-01-27
|
* Do not include mathematics.h in avutil.hMans Rullgard2011-07-03
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* setdar: prefer "sar" over "par" in log info messageStefano Sabatini2011-04-25
| | | | | | | This is more consistent with the terminology adopted by the aspect filter names. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add sample_aspect_ratio to AVFilterLinkMichael Niedermayer2011-02-14
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* In aspect filter, fix display for input resolutionBaptiste Coudurier2010-11-24
| | | | Originally committed as revision 25819 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reindent.Stefano Sabatini2010-11-22
| | | | Originally committed as revision 25803 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement robust parsing in aspect filters.Stefano Sabatini2010-11-22
| | | | Originally committed as revision 25802 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add informative log messages to the set aspect filters.Stefano Sabatini2010-11-22
| | | | Originally committed as revision 25801 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give more explicit/less confusing names to the filters dealing withStefano Sabatini2010-11-22
| | | | | | aspect ratio. Originally committed as revision 25800 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Log error message in case of invalid parsing.Stefano Sabatini2010-11-18
| | | | Originally committed as revision 25765 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix style: if( -> if (.Stefano Sabatini2010-11-18
| | | | Originally committed as revision 25764 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove redundant information in header.Stefano Sabatini2010-11-18
| | | | Originally committed as revision 25763 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Separate video specific BufferRef properties into VideoProps.S.N. Hemanth Meenakshisundaram2010-08-11
| | | | | | | | | | | | Define a new struct AVFilterBufferRefVideoProps and add a type field to AVFilterBufferRef. Video specific properties in AVFilterBufferRefVideoProps are now referred to by *video pointer in AVFilterBufferRef. Patch by S.N. Hemanth Meenakshisundaram smeenaks->ucsd.edu. Originally committed as revision 24763 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename AVFilterPicRef to AVFilterBufferRef.S.N. Hemanth Meenakshisundaram2010-08-07
| | | | | | | | | The struct is going to be used for storing audio buffer references as well, and the new name is more generic. Patch by S.N. Hemanth Meenakshisundaram @smeenaks@ucsd@edu@. Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use the new null callbacks to simplify filters and reduce duplicated code.Bobby Bingham2010-03-18
| | | | Originally committed as revision 22595 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add video filter to manipulate aspect ratioBobby Bingham2010-03-17
Originally committed as revision 22573 to svn://svn.ffmpeg.org/ffmpeg/trunk