summaryrefslogtreecommitdiff
path: root/libavfilter/graphparser.c
Commit message (Expand)AuthorAge
* Rename avfilter_parse_graph() to avfilter_graph_parse(), for betterStefano Sabatini2009-02-26
* Rename avfilter_destroy_graph() to avfilter_graph_destroy(), for betterStefano Sabatini2009-02-26
* Fix avfilter_parse_graph() invalid graph description detection.Stefano Sabatini2009-02-14
* Print a warning and fail if the graph description cannot beStefano Sabatini2009-01-16
* Change thisIsAVar variable names to this_is_a_var style, moreStefano Sabatini2008-12-27
* Fix typo: ommitted -> omitted.Stefano Sabatini2008-12-26
* Choose better names for the variables in create_filter().Stefano Sabatini2008-12-26
* Split openLinks linked list into openInputs and openOutputsVitor Sessak2008-05-24
* One more memory leakVitor Sessak2008-05-24
* Cosmetical: move statementVitor Sessak2008-05-24
* Plug some memory leaksVitor Sessak2008-05-24
* Merge variable initialization and declarationVitor Sessak2008-05-24
* CosmeticsVitor Sessak2008-05-24
* Remove unnused varVitor Sessak2008-05-24
* SimplifyVitor Sessak2008-05-24
* Use av_mallocz instead of av_malloc to simplify some codeVitor Sessak2008-05-24
* Factor linked list insertion in its own functionVitor Sessak2008-05-24
* Remove comment redundant with those in graphparser.hVitor Sessak2008-05-24
* These error messages should print the filter name, not the instance nameVitor Sessak2008-05-24
* 10l: fix previous commitVitor Sessak2008-05-24
* SimplifyVitor Sessak2008-05-24
* Remove senseless commentsVitor Sessak2008-05-24
* Cosmetics: split setting a var and checking for errorVitor Sessak2008-05-24
* Fix doxy commentVitor Sessak2008-05-24
* Make parse_link_name() return a pointer to the name readVitor Sessak2008-05-24
* Cosmetics: more function reorderingVitor Sessak2008-05-24
* Make consume_whitespace() return a number of bytes to be skipedVitor Sessak2008-05-24
* Cosmetics: change function orderVitor Sessak2008-05-24
* SimplifyVitor Sessak2008-05-24
* Pass the inputs and outputs of avfilter_parse_graph() with a AVFilterInOut li...Vitor Sessak2008-05-24
* Cosmetics: more indentation consistencyVitor Sessak2008-05-24
* More cosmetics: make indentation more consistentVitor Sessak2008-05-24
* More cosmeticsVitor Sessak2008-05-24
* Move code out of ifVitor Sessak2008-05-24
* CosmeticsVitor Sessak2008-05-24
* CosmeticsVitor Sessak2008-05-24
* Factor common code out of ifVitor Sessak2008-05-24
* Rename another varVitor Sessak2008-05-24
* Rename varVitor Sessak2008-05-24
* Move var declaration to where it is neededVitor Sessak2008-05-24
* Replace if(!a){B}else{C} by if(a){C}else{B}Vitor Sessak2008-05-24
* Remove useless assignmentVitor Sessak2008-05-24
* Simplify while(pad){pad--; etc} to while(pad--){etc}Vitor Sessak2008-05-24
* Simplify extract_inout() as suggested by MichaelVitor Sessak2008-05-24
* Change the parser logic following Michael's reviewVitor Sessak2008-05-24
* The name field of AVFilterInOut can be declared constVitor Sessak2008-05-24
* A semi-colon is also a string endVitor Sessak2008-05-24
* 10l: Missed that in one of the last commitsVitor Sessak2008-05-24
* Move code from handle_link() to the only place the function is calledVitor Sessak2008-05-24
* SimplifyVitor Sessak2008-05-24