summaryrefslogtreecommitdiff
path: root/libavfilter/avfiltergraph.c
Commit message (Collapse)AuthorAge
* avfiltergraph: check the query_formats() return valueAnton Khirnov2016-05-23
|
* lavfi: Drop deprecated *_count suffixed variablesVittorio Giovara2015-08-28
| | | | Deprecated in 06/2012.
* lavfi: allow user-provided execute() callbacksAnton Khirnov2013-09-28
|
* lavfi: add const to the AVFilter parameter of avfilter_graph_create_filter()Anton Khirnov2013-08-04
| | | | This function should never modify the filter.
* Disable deprecation warnings for cases where a replacement is availableDiego Biurrun2013-08-02
|
* lavfi: add a slice threading infrastructureAnton Khirnov2013-05-24
| | | | Mostly based on libavcodec's
* lavfi: rename AVFilterFormats.format_count to nb_formatsAnton Khirnov2013-05-17
| | | | This is more consistent with naming in the rest of Libav.
* avfiltergraph: simplify inserting conversion filters.Anton Khirnov2013-05-15
| | | | | There is now no need to explicitly pass 0:0 as width/height to scale, those are the defaults.
* lavfi: add avfilter_init_str() to replace avfilter_init_filter().Anton Khirnov2013-04-11
| | | | Drop the unused opaque parameter from its signature.
* lavfi: make avfilter_free() remove the filter from its graph.Anton Khirnov2013-04-11
|
* lavfi: add AVFilterContext.graph.Anton Khirnov2013-04-11
| | | | It will be useful in the following commits.
* lavfi: deprecate avfilter_graph_add_filter().Anton Khirnov2013-04-11
| | | | | | Since this function adds a standalone filter to a filter graph and we do not support creating such filters, there is no reason for this function to exist.
* lavfi: replace avfilter_open() with avfilter_graph_alloc_filter().Anton Khirnov2013-04-11
| | | | | | | Since we do not support "standalone" filters not attached to an AVFilterGraph, we should not have a public function to create such filters. In addition that function is horribly named, the action it does cannot be possibly described as "opening" a filter.
* lavfi: merge avfiltergraph.h into avfilter.hAnton Khirnov2013-04-11
| | | | | We do not support using filters without AVFilterGraph in practice anyway, so there is no point in pretending we do.
* avfiltergraph: set deprecated filter_count.Anton Khirnov2013-04-04
|
* avfiltergraph: check for sws opts being non-NULL before using them.Anton Khirnov2013-04-03
| | | | | | Avoid snprintfing a NULL pointer. CC: libav-stable@libav.org
* avfiltergraph: use sizeof(var) instead of sizeof(type)Anton Khirnov2013-03-16
|
* avfiltergraph: replace AVFilterGraph.filter_count with nb_filtersAnton Khirnov2013-03-16
| | | | This is more consistent with the naming in the rest of Libav.
* Use the avstring.h locale-independent character type functionsReimar Döffinger2013-03-07
| | | | | | Make sure the behavior does not change with the locale. Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: connect libavresample options to af_resample via AVFilterGraphJustin Ruggles2013-02-23
|
* Include libavutil/channel_layout.h instead of libavutil/audioconvert.hJustin Ruggles2012-11-11
| | | | Also reorder some other #include when applicable.
* avfiltergraph: silence an uninitialized variable warningAnton Khirnov2012-09-17
| | | | | | | | | | The warning is: libavfilter/avfiltergraph.c: In function ‘avfilter_graph_config’: libavfilter/avfiltergraph.c:528:9: warning: ‘best_idx’ may be used uninitialized in this function [-Wuninitialized] libavfilter/avfiltergraph.c:479:13: note: ‘best_idx’ was declared here Initialize it to an invalid value and add an assert that it's properly set later.
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* lavfi: better channel layout negotiationJustin Ruggles2012-07-27
| | | | | | | Allow substitution of channel pairs in the input for nearby channel pairs in the output in order to get a closer match. Also weigh LFE channel mismatch differently to favor matching the same layout without LFE over one less channel with LFE.
* avfiltergraph: shut up uninitialized variable warning.Anton Khirnov2012-06-26
| | | | | | The warning silenced was: libavfilter/avfiltergraph.c: In function ‘avfilter_graph_config’: libavfilter/avfiltergraph.c:500:13: warning: ‘best_idx’ may be used uninitialized in this function [-Wuninitialized]
* lavfi: remove disabled FF_API_GRAPH_AVCLASS cruftAnton Khirnov2012-06-26
|
* lavfi: support automatically inserting the fifo filter when needed.Anton Khirnov2012-06-22
| | | | This breaks libavfilter ABI.
* avfiltergraph: remove a redundant call to avfilter_get_by_name().Anton Khirnov2012-06-13
|
* lavfi: allow building without swscale.Anton Khirnov2012-06-13
|
* lavfi: replace AVFilterContext.input/output_count with nb_inputs/outputsAnton Khirnov2012-06-13
| | | | This is more consistent with naming in the rest of Libav.
* lavfi: make formats API private on next bump.Anton Khirnov2012-06-05
| | | | | It is only useful inside filters and we don't allow user filters for now.
* avfiltergraph: make some functions static.Anton Khirnov2012-06-04
| | | | They are not used outside of avfiltergraph.c
* lavfi: remove avfilter_default_* from public API on next bump.Anton Khirnov2012-05-22
| | | | | Those functions are only useful inside filters. It is better to not support user filters until the API is more stable.
* avfiltergraph: smarter sample format selection.Anton Khirnov2012-05-22
|
* avfiltergraph: reindentAnton Khirnov2012-05-14
|
* lavfi: add channel layout/sample rate negotiation.Anton Khirnov2012-05-14
|
* lavfi: autoinsert resample filter when necessary.Anton Khirnov2012-05-12
|
* avfiltergraph: try to reduce format conversions in filters.Anton Khirnov2012-04-01
| | | | | | | | | | | | | Current code, with a filterchain such as (input - yuv411) -> (scale - any) -> (sink - any) will result in yuv420 being chosen for the second link, which is clearly not right. This commit attempts to improve in the following way: repeat until convergence: loop over all filters find input link with exactly one format force this format on all output links of the same type (if possible)
* avfiltergraph: add an AVClass to AVFilterGraph on next major bump.Anton Khirnov2012-04-01
| | | | It will be used for logging, possibly also AVOptions.
* lavfi: fix signature for avfilter_graph_parse() and avfilter_graph_config()Stefano Sabatini2011-09-28
| | | | | | Require "void *" rather than "AVClass *" for the log context type. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* avfiltergraph: use meaningful error codesStefano Sabatini2011-09-28
| | | | Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Make avfilter_graph_free() free the graph.Stefano Sabatini2011-02-04
| | | | | | | | | | Make avfilter_graph_free() free not only the internal structures, but also the allocated graph, and set the graph pointer to NULL for increased safety. Simplify usage. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Make avfilter_graph_free() do nothing if graph is NULL.Stefano Sabatini2011-01-12
| | | | Originally committed as revision 26323 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix style nits in avfiltergraph.c.Stefano Sabatini2010-12-28
| | | | Originally committed as revision 26116 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add avfilter_graph_create_filter().Stefano Sabatini2010-12-02
| | | | Originally committed as revision 25862 to svn://svn.ffmpeg.org/ffmpeg/trunk
* In libavfilter, use consistently "Copyright (c)" in the licenseStefano Sabatini2010-11-28
| | | | | | headers. Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Prefix with "ff_" the functions:Stefano Sabatini2010-11-13
| | | | | | | | | | | | ff_avfilter_graph_check_validity() ff_avfilter_graph_config_links() ff_avfilter_graph_config_formats() and move their declaration to internal.h. These functions are never used in application code, so it is better to consider them internal functions, this can be changed later if necessary. Simplify API. Originally committed as revision 25737 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename avfilter_destroy() as avfilter_free().Stefano Sabatini2010-11-08
| | | | | | | The new name is shorter and more consistent with the FFmpeg API, and sounds less evil. Originally committed as revision 25707 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename avfilter_graph_destroy() to avfilter_graph_free().Stefano Sabatini2010-11-04
| | | | | | | | The new name is shorter and more consistent with the rest of the API. This change breaks libavfilter API/ABI. Originally committed as revision 25674 to svn://svn.ffmpeg.org/ffmpeg/trunk