summaryrefslogtreecommitdiff
path: root/libavcore
Commit message (Collapse)AuthorAge
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* consolidate .gitignore patters into a single fileJanne Grunau2011-01-18
| | | | Signed-off-by: Janne Grunau <janne-ffmpeg@jannau.net>
* convert svn:ignore properties to .gitignore filesJanne Grunau2011-01-17
| | | | Signed-off-by: Janne Grunau <janne-ffmpeg@jannau.net>
* Add avcore.h header in samplefmt.h.Stefano Sabatini2011-01-14
| | | | | | | Avoid the need to manually include the avcore.h header, less error-prone. Originally committed as revision 26333 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make av_get_channel_layout_string() guess the number of channels if itStefano Sabatini2011-01-13
| | | | | | was not provided. Originally committed as revision 26324 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move AV_NOPTS_VALUE, AV_TIME_BASE, AV_TIME_BASE_Q symbols fromStefano Sabatini2010-12-09
| | | | | | | | libavcodec to libavcore. Remove another compile-time dependancy of libavfilter on libavcodec. Originally committed as revision 25923 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement av_image_alloc() and use it inStefano Sabatini2010-12-04
| | | | | | avfilter_default_get_video_buffer(). Originally committed as revision 25878 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing overflow checks in av_image_fill_pointers() andStefano Sabatini2010-12-02
| | | | | | av_image_fill_linesizes(). Originally committed as revision 25861 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move audio channel API from libavcodec to libavcore.Stefano Sabatini2010-11-21
| | | | Originally committed as revision 25787 to svn://svn.ffmpeg.org/ffmpeg/trunk
* move the av_parse_color() function from libavfilter to libavcoreAurelien Jacobs2010-11-17
| | | | Originally committed as revision 25761 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move internal function ff_set_systematic_pal() to libavcore, andStefano Sabatini2010-11-09
| | | | | | rename it ff_set_systematic_pal2(). Originally committed as revision 25712 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use hierarchic names convention (prefix them with av_expr) for theStefano Sabatini2010-11-08
| | | | | | | | | eval API. More grep-friendly and more consistent with the rest of the FFmpeg API. Originally committed as revision 25708 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add av_get_bits_per_sample_fmt() to libavcore/samplefmt.h andStefano Sabatini2010-11-02
| | | | | | deprecate av_get_bits_per_sample_format(). Originally committed as revision 25654 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement functions:Stefano Sabatini2010-11-02
| | | | | | | | | | | | | av_get_sample_fmt_name() av_get_sample_fmt() av_get_sample_fmt_string() in libavcore, and deprecate the corresponding libavcodec/audioconvert.h functions: avcodec_get_sample_fmt_name() avcodec_get_sample_fmt() avcodec_sample_fmt_string() Originally committed as revision 25653 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move sample format definitions from libavcodec to libavcore.Stefano Sabatini2010-11-02
| | | | Originally committed as revision 25652 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add a test for av_parse_video_rate().Stefano Sabatini2010-10-04
| | | | Originally committed as revision 25334 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use av_parse_and_eval_expr() in av_parse_video_rate(), simplify.Stefano Sabatini2010-10-04
| | | | Originally committed as revision 25333 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix weird indent.Stefano Sabatini2010-10-01
| | | | Originally committed as revision 25287 to svn://svn.ffmpeg.org/ffmpeg/trunk
* av_fill_image_linesizes -> av_image_fill_linesizesRamiro Polla2010-09-08
| | | | Originally committed as revision 25083 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing checks on invalid pixel format inStefano Sabatini2010-09-07
| | | | | | av_image_fill_linesizes/pointers. Originally committed as revision 25072 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: use plural form for *linesizes arguments ofStefano Sabatini2010-09-07
| | | | | | | av_image_copy(), more consistent with the rest of the API and more semantically correct. Originally committed as revision 25070 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move av_picture_data_copy() to libavcore, and rename itStefano Sabatini2010-09-07
| | | | | | av_image_copy(). Originally committed as revision 25067 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reimplement ff_img_copy_plane() as av_image_copy_plane() in libavcore,Stefano Sabatini2010-09-07
| | | | | | and deprecate the old function. Originally committed as revision 25064 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Adopt a hierarchical name scheme for the imgutils.h API. SimplifyStefano Sabatini2010-09-07
| | | | | | | grepping and somewhat more consistent with the scheme adopted by other FFmpeg modules API. Originally committed as revision 25057 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make av_fill_image_max_pixsteps() non static non inline.Stefano Sabatini2010-09-06
| | | | Originally committed as revision 25053 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use quotes instead of angle brackets for local #includes.Diego Biurrun2010-09-01
| | | | Originally committed as revision 25015 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: if( -> if (.Stefano Sabatini2010-08-21
| | | | Originally committed as revision 24859 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().Stefano Sabatini2010-08-20
| | | | | | | | | | The plural form is preferred as it is more consistent with the other functions: av_fill_image_linesizes() av_fill_image_pointers() and looks semantically more correct as it fills an array of elements. Originally committed as revision 24851 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add missing period in av_fill_image_max_pixstep() doxy.Stefano Sabatini2010-08-20
| | | | Originally committed as revision 24850 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement inline function av_fill_image_max_pixstep() and use it forStefano Sabatini2010-08-18
| | | | | | factorizing code. Originally committed as revision 24827 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement av_get_image_linesize() and use it inStefano Sabatini2010-08-12
| | | | | | | | ff_get_plane_bytewidth(). The new implementation is more generic, more compact and more correct. Originally committed as revision 24786 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Clarify av_check_image_size() log message.Stefano Sabatini2010-08-06
| | | | Originally committed as revision 24710 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Deprecate avcodec_check_dimensions() in favor of the new functionStefano Sabatini2010-08-06
| | | | | | av_check_image_size() declared in libavcore/imgutils.h. Originally committed as revision 24709 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename the av_fill_image_linesize() formal parameter linesize toStefano Sabatini2010-07-30
| | | | | | linesizes, for consistency with the function declaration. Originally committed as revision 24591 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reimplement av_fill_image_pointers() using the information stored inStefano Sabatini2010-07-30
| | | | | | | | | the pixdescs. The new implementation is more compact, and does not need to be updated at each pixel format addition. Originally committed as revision 24590 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make av_fill_image_linesizes() return a meaningful error core ratherStefano Sabatini2010-07-30
| | | | | | than -1. Originally committed as revision 24589 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename av_fill_image_linesizes() internal variables max_plane_step andStefano Sabatini2010-07-30
| | | | | | | | | max_plane_step_comp by removing the "plane_" word, and add a comment for explaining what they represent. Increase readability. Originally committed as revision 24588 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move fill_image_linesize() and fill_image_data_ptr() fromStefano Sabatini2010-07-29
| | | | | | | libavcodec/imgconvert.c and make them public in libavcore/imgutils.h, with the names av_fill_image_linesizes() and av_fill_image_pointers(). Originally committed as revision 24583 to svn://svn.ffmpeg.org/ffmpeg/trunk
* libavcore needs libavutilMåns Rullgård2010-07-27
| | | | Originally committed as revision 24532 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Avoid the use of an intermediary variable inStefano Sabatini2010-07-26
| | | | | | av_parse_video_rate(). Simplify. Originally committed as revision 24524 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make VideoFrameRateAbbr contain a rational rather than two ints forStefano Sabatini2010-07-26
| | | | | | num and den. Simplify. Originally committed as revision 24523 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove reference to the "frame" term in variable names. Simpler andStefano Sabatini2010-07-26
| | | | | | more consistent with the function names. Originally committed as revision 24522 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make av_parse_video_size() and av_parse_video_rate() returnStefano Sabatini2010-07-26
| | | | | | AVERROR(EINVAL) rather than -1 in case of unsuccess. Originally committed as revision 24521 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Deprecate av_parse_video_frame_size() and av_parse_video_frame_rate()Stefano Sabatini2010-07-26
| | | | | | | | | | | in favor of the newly added corresponding functions av_parse_video_size() and av_parse_video_rate() defined in libavcore/parseutils.h. This change also adds a linking-time dependency of libavcodec and of libavfilter on libavcore. Originally committed as revision 24518 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add libavcore.Stefano Sabatini2010-07-21
The new library is meant to contain the core multimedia utilities for FFmpeg, to make them shareable between more libav* libraries. See thread: Subject: [FFmpeg-devel] [RFC] New library for shared non-generic libav* utils Date: Fri, 9 Jul 2010 01:07:40 +0200 Originally committed as revision 24393 to svn://svn.ffmpeg.org/ffmpeg/trunk