summaryrefslogtreecommitdiff
path: root/libavcodec/xsubdec.c
Commit message (Collapse)AuthorAge
* Reduce the scope of some variablesDiego Biurrun2016-05-11
| | | | | This avoids unused variable warnings after the next version bump. Also drop a trace level av_log() call that is in the way.
* lavc: Add data and linesize to AVSubtitleRectVittorio Giovara2015-10-21
| | | | | | | | | | | | Use the new fields directly instead of the ones from AVPicture. This removes a layer of indirection which serves no pratical purpose whatsoever, and will help in removing AVPicture structure completely later. Every subtitle encoder/decoder seamlessly points to the new arrays, so it is possible to deprecate AVSubtitleRect.pict. Signed-off-by: Vittorio Giovara <vittorio.giovara@gmail.com>
* xsub: Check memory allocationVittorio Giovara2015-05-31
|
* xsub: Support DXSA subtitlesAlexandre Colucci2015-01-07
| | | | | | | | These have a DXSA tag and contain alpha in addition to color values for palette. Signed-off-by: Jean-Baptiste Kempf <jb@videolan.org> Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* cosmetics: Group .name and .long_name together in codec/format declarationsDiego Biurrun2013-10-03
|
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* xsub: feed init_get_bits the whole bufferAlexandre Colucci2012-09-25
| | | | | | | | | | | Do not use rlelen field for buffer size in init_get_bits, it is only the size of the data for the first field. Since it is not reliable, just use the size of the whole buffer. Additional comments add removal of unused rlelen variable by Reimar Döffinger. Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* cosmetics: fix indentation/alignment in AVCodec declarationsDiego Biurrun2011-08-03
|
* lavc: use designated initialisers for all codecs.Anton Khirnov2011-07-29
| | | | It's more readable and less prone to breakage.
* Do not include mathematics.h in avutil.hMans Rullgard2011-07-03
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Merge libavcore into libavutilReinhard Tartler2011-02-15
| | | | | | | | | | | | It is pretty hopeless that other considerable projects will adopt libavutil alone in other projects. Projects that need small footprint are better off with more specialized libraries such as gnulib or rather just copy the necessary parts that they need. With this in mind, nobody is helped by having libavutil and libavcore split. In order to ease maintenance inside and around FFmpeg and to reduce confusion where to put common code, avcore's functionality is merged (back) to avutil. Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* Add ff_ prefix to data symbols of encoders, decoders, hwaccel, parsers, bsf.Diego Elio Pettenò2011-01-26
| | | | | | | None of these symbols should be accessed directly, so declare them as hidden. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Use new imgutils.h API names, fix deprecation warnings.Stefano Sabatini2010-09-07
| | | | Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove use of the deprecated function avcodec_check_dimensions(), useStefano Sabatini2010-08-06
| | | | | | av_check_image_size() instead. Originally committed as revision 24711 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Always allocate a buffer of AVPALETTE_SIZE for palette in the subtitleReimar Döffinger2009-08-20
| | | | | | | decoders instead of as small as possible. This avoids completely unnecessary issues with e.g. libswscale. Originally committed as revision 19673 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix start_display_time/end_display_time to be relative to packet pts in xsub ↵Reimar Döffinger2009-08-15
| | | | | | | | decoder. Makes no difference for the sample AVI files since they all have no packet pts values. Originally committed as revision 19646 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reindent.Reimar Döffinger2009-08-15
| | | | Originally committed as revision 19645 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove code that is now dead.Reimar Döffinger2009-08-15
| | | | Originally committed as revision 19644 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make sure AVSubtitle is initialized, memset it to 0.Reimar Döffinger2009-08-15
| | | | Originally committed as revision 19642 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Set subtitle type in DVD and XSUB subtitle decoders.Janne Grunau2009-07-26
| | | | | | Patch by Janne Grunau <ja?ne-f?mpeg jannau net>. Originally committed as revision 19512 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename bitstream.h to get_bits.h.Stefano Sabatini2009-04-13
| | | | Originally committed as revision 18494 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement avcodec_decode_video2(), _audio3() and _subtitle2() which takes anThilo Borgmann2009-04-07
| | | | | | | | | | | AVPacket argument rather than a const uint8_t *buf + int buf_size. This allows passing of packet-specific flags from demuxer to decoder, such as the keyframe flag, which appears necessary to playback corePNG P-frames. Patch by Thilo Borgmann thilo.borgmann googlemail com, see also the thread "Google Summer of Code participation" on the mailinglist. Originally committed as revision 18351 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Set AVSubtitle format to 0. Neither dvdsubdec nor xsubdec intializes formatBjörn Axelsson2009-02-12
| | | | | | | to 0, but ffplay checks it before displaying subtitles (ffplay.c:1437). patch by Björn Axelsson, gecko acc.umu se Originally committed as revision 17170 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix timestamp parsing in XSUB decoder.Björn Axelsson2009-02-09
| | | | | | Patch by Björn Axelsson gecko A acc D umu D se Originally committed as revision 17087 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Replace AVSubtitleRect.rgba_palette and bitmap by AVPicture.Michael Niedermayer2009-01-03
| | | | Originally committed as revision 16416 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change AVSubtitle.rects to an array of pointers so ABI does not breakMichael Niedermayer2009-01-03
| | | | | | when the size of AVSubtitleRect changes. Originally committed as revision 16412 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make AVCodec long_names definition conditional depending on CONFIG_SMALL.Stefano Sabatini2008-06-12
| | | | Originally committed as revision 13759 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add long names to many AVCodec declarations.Stefano Sabatini2008-04-27
| | | | | | patch by Stefano Sabatini, stefano.sabatini-lala poste it Originally committed as revision 13005 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Apply 'cold' attribute to init/uninit functions in libavcodecZuxy Meng2008-03-21
| | | | Originally committed as revision 12525 to svn://svn.ffmpeg.org/ffmpeg/trunk
* constsMichael Niedermayer2008-02-01
| | | | | | I have underestimated this a little, and these are just some ... Originally committed as revision 11708 to svn://svn.ffmpeg.org/ffmpeg/trunk
* colour --> color in variable namesDiego Biurrun2007-12-03
| | | | Originally committed as revision 11159 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add proper license headerReimar Döffinger2007-08-05
| | | | Originally committed as revision 9944 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove AVCodecContext parameter from parse_timecode functionReimar Döffinger2007-08-05
| | | | Originally committed as revision 9943 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix deinterlacing for odd heightReimar Döffinger2007-08-05
| | | | Originally committed as revision 9942 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Deinterlace xsub subtitlesReimar Döffinger2007-08-05
| | | | Originally committed as revision 9941 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Colours except background should not be transparentReimar Döffinger2007-08-05
| | | | Originally committed as revision 9940 to svn://svn.ffmpeg.org/ffmpeg/trunk
* get rid of av_rescale_q, it does not work as intended.Reimar Döffinger2007-08-05
| | | | Originally committed as revision 9939 to svn://svn.ffmpeg.org/ffmpeg/trunk
* get rid of xsubdec array and calculate value insteadReimar Döffinger2007-08-05
| | | | Originally committed as revision 9938 to svn://svn.ffmpeg.org/ffmpeg/trunk
* 10l, runbits order was reversedReimar Döffinger2007-08-05
| | | | Originally committed as revision 9937 to svn://svn.ffmpeg.org/ffmpeg/trunk
* 100l, wrong argument to av_freepReimar Döffinger2007-08-05
| | | | Originally committed as revision 9935 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add forgotten xsub timecode parsingReimar Döffinger2007-08-05
| | | | Originally committed as revision 9934 to svn://svn.ffmpeg.org/ffmpeg/trunk
* First version of xsub decoder, not yet testedReimar Döffinger2007-08-05
Originally committed as revision 9933 to svn://svn.ffmpeg.org/ffmpeg/trunk