summaryrefslogtreecommitdiff
path: root/libavcodec/vaapi_internal.h
Commit message (Collapse)AuthorAge
* mpegvideo: Drop mpegvideo.h where not neededVittorio Giovara2015-09-13
| | | | Add necessary headers in .c files.
* vaapi: switch ff_vaapi_get_surface_id from Picture to AVFramewm42014-03-20
| | | | Signed-off-by: Anton Khirnov <anton@khirnov.net>
* h264: deMpegEncContextizeAnton Khirnov2013-02-15
| | | | | | | | | | | | | | | | | | | | | | | | | | | Most of the changes are just trivial are just trivial replacements of fields from MpegEncContext with equivalent fields in H264Context. Everything in h264* other than h264.c are those trivial changes. The nontrivial parts are: 1) extracting a simplified version of the frame management code from mpegvideo.c. We don't need last/next_picture anymore, since h264 uses its own more complex system already and those were set only to appease the mpegvideo parts. 2) some tables that need to be allocated/freed in appropriate places. 3) hwaccels -- mostly trivial replacements. for dxva, the draw_horiz_band() call is moved from ff_dxva2_common_end_frame() to per-codec end_frame() callbacks, because it's now different for h264 and MpegEncContext-based decoders. 4) svq3 -- it does not use h264 complex reference system, so I just added some very simplistic frame management instead and dropped the use of ff_h264_frame_start(). Because of this I also had to move some initialization code to svq3. Additional fixes for chroma format and bit depth changes by Janne Grunau <janne-libav@jannau.net> Signed-off-by: Anton Khirnov <anton@khirnov.net>
* hwaccel: unbreak buildMans Rullgard2011-07-10
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* doxygen: Consistently use '@' instead of '\' for Doxygen markup.Diego Biurrun2011-06-24
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Rename ff_vaapi_alloc_picture() to ff_vaapi_alloc_pic_param().Gwenole Beauchesne2009-12-28
| | | | Originally committed as revision 20942 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename ff_vaapi_get_surface() to ff_vaapi_get_surface_id().Gwenole Beauchesne2009-12-28
| | | | Originally committed as revision 20941 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Improve VA API buffers allocation logic. This also reduces struct vaapi_contextGwenole Beauchesne2009-03-31
| | | | | | down to ~60 bytes vs. a few KBs before, and gets rid of explicit VA data types. Originally committed as revision 18256 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add common VA API data structures and helpers.Gwenole Beauchesne2009-03-22
Originally committed as revision 18136 to svn://svn.ffmpeg.org/ffmpeg/trunk