summaryrefslogtreecommitdiff
path: root/libavcodec/ra288.c
Commit message (Expand)AuthorAge
* Do not reimplement ff_celp_lp_synthesis_filterf().Vitor Sessak2009-02-24
* Use ff_dot_productf() in ra288.cVitor Sessak2008-10-30
* Simplify: avoid duplication backward_filter()Vitor Sessak2008-09-26
* Do instead of divising a float by a constant, multiply by its inverseVitor Sessak2008-09-25
* Move constant multiplication out of the loopVitor Sessak2008-09-24
* Cosmetics: move convolve() together with the other DSP functionsVitor Sessak2008-09-24
* Simplify: move division by constant off the loopVitor Sessak2008-09-24
* Merge the 2 lpc loops.Michael Niedermayer2008-09-23
* Factorize lpc code slightly.Michael Niedermayer2008-09-23
* Use SAMPLE_FMT_FLT instead of doing the float->int conversion in theVitor Sessak2008-09-17
* Cosmetics: line breaksVitor Sessak2008-09-13
* Simplify: use a single history buffer for gain and a single one forVitor Sessak2008-09-13
* Cosmetics: align spec referencesVitor Sessak2008-09-11
* Rename function: s/colmult/apply_window/Vitor Sessak2008-09-11
* misc spelling/wording/grammar fixesDiego Biurrun2008-09-11
* Convert table to integer.Vitor Sessak2008-09-10
* Avoid duplicating compute_lpc_coefs() function in both the RA288 and AAC deco...Vitor Sessak2008-09-04
* Check *data_size in decode_frame()Vitor Sessak2008-08-06
* Cosmetics: alignmentVitor Sessak2008-08-06
* Flip (by making buf[i] -> buf[size-i-1]) two buffers: {sp,gain}_block. ThisVitor Sessak2008-08-06
* Rename prodsum() function to convolve()Vitor Sessak2008-08-05
* Modify all codecs to report their supported input and output sample format(s).Peter Ross2008-07-31
* Do not declare a counter as unsigned when it is not neededVitor Sessak2008-07-29
* Cosmetics: rename loop counter vars to i,jVitor Sessak2008-07-29
* Cosmetics: new lineVitor Sessak2008-07-28
* Remove the now useless phase variable from contextVitor Sessak2008-07-28
* Cosmetics: make comment match var nameVitor Sessak2008-07-28
* Cosmetics: align commentsVitor Sessak2008-07-28
* Rename two context vars: s/sb/sp_block/, s/lhist/gain_block/Vitor Sessak2008-07-28
* Declare temporary buffers to be only of the necessary sizeVitor Sessak2008-07-28
* Remove redundant commentsVitor Sessak2008-07-28
* Cosmetics: do not align with now removed next instructionVitor Sessak2008-07-28
* Cosmetics: remove braces and useless newlineVitor Sessak2008-07-28
* Change the way the input is passed to do_hybrid_filter(). Before, in[0] wasVitor Sessak2008-07-28
* Remove RA288Context.output buffer. This buffer is just RA288Context.sbVitor Sessak2008-07-28
* Add a few comments pointing to the G.728 specificationVitor Sessak2008-07-27
* Remove the history buffer from the context. It can easily be evaluatedVitor Sessak2008-07-27
* Rename two context buffers: pr{1,2} -> {sp,gain}_lpc. Also add a few doxyVitor Sessak2008-07-27
* Remove st1 and st2 temporary buffers in backward_filter() and use insteadVitor Sessak2008-07-27
* Change slightly the meaning of RA288Context.phase. ThisVitor Sessak2008-07-27
* Remove st1 and st2 variables from context, since they could be just local varsVitor Sessak2008-07-26
* Rename st{1,2}{a,b} context variables to more meaningful names: {sp,gain}_{re...Vitor Sessak2008-07-26
* Cosmetics: remove useless parenthesisVitor Sessak2008-07-26
* Move colmult() function to the beginning of file to group DSP-related functions.Vitor Sessak2008-07-26
* Remove an useless comment describing colmult()Vitor Sessak2008-07-26
* Remove an useless comment describing prodsum()Vitor Sessak2008-07-26
* Give the context variables of ra288 a better name: s/glob/ractx/Vitor Sessak2008-07-26
* Give the context structure of ra288 a better name: s/Real288_internal/RA288Co...Vitor Sessak2008-07-26
* Cosmetics: grammar nitsVitor Sessak2008-07-24
* Rename update() function to backward_filter() and add a doxy commentVitor Sessak2008-07-24