summaryrefslogtreecommitdiff
path: root/libavcodec/ra144.c
Commit message (Collapse)AuthorAge
* cosmetics: Fix spelling mistakesVittorio Giovara2016-05-04
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* avcodec: Drop unnecessary ff_ name prefixes from static functionsDiego Biurrun2013-04-30
|
* Move avutil tables only used in libavcodec to libavcodec.Diego Biurrun2012-10-11
|
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* Add a shift parameter to celp_lp_synthesis_filter()Mohamed Naufal Basheer2012-07-22
| | | | | | This is intended for reuse by the G.723.1 decoder Signed-off-by: Kostya Shishkov <kostya.shishkov@gmail.com>
* ra144: use macro constants to make the code more understandable.Justin Ruggles2011-10-10
|
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Make ff_add_wav static to ra144.cDiego Elio Pettenò2011-01-25
| | | | Signed-off-by: Janne Grunau <janne-ffmpeg@jannau.net>
* Split do_output_subblock() into common code and decoder specific partsFrancesco Lavra2010-06-11
| | | | | | Patch by Francesco Lavra (firstnamelastname@interfree.it) Originally committed as revision 23576 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: indentFrancesco Lavra2010-06-11
| | | | | | Patch by Francesco Lavra (firstnamelastname@interfree.it) Originally committed as revision 23575 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add ff_ prefix to non-static functionsFrancesco Lavra2010-06-11
| | | | | | Patch by Francesco Lavra (firstnamelastname@interfree.it) Originally committed as revision 23574 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split ra144.c in common code (to be shared with the future encoder) andFrancesco Lavra2010-06-11
| | | | | | | | decoder. Patch by Francesco Lavra (firstnamelastname@interfree.it) Originally committed as revision 23573 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move ff_sqrt() to libavutil/intmath.hMåns Rullgård2010-03-08
| | | | Originally committed as revision 22345 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix reading beyond buffer end on RA144Context.lpc_tables.Francesco Lavra2010-02-13
| | | | | | Patch by Francesco Lavra (francescolavra -at- interfree -dot- it) Originally committed as revision 21796 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use correct context for av_log(), should prevent a crash for malformed files.Francesco Lavra2010-01-05
| | | | | | Patch by Francesco Lavra (francescolavra at interfree dot it). Originally committed as revision 21031 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename bitstream.h to get_bits.h.Stefano Sabatini2009-04-13
| | | | Originally committed as revision 18494 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Implement avcodec_decode_video2(), _audio3() and _subtitle2() which takes anThilo Borgmann2009-04-07
| | | | | | | | | | | AVPacket argument rather than a const uint8_t *buf + int buf_size. This allows passing of packet-specific flags from demuxer to decoder, such as the keyframe flag, which appears necessary to playback corePNG P-frames. Patch by Thilo Borgmann thilo.borgmann googlemail com, see also the thread "Google Summer of Code participation" on the mailinglist. Originally committed as revision 18351 to svn://svn.ffmpeg.org/ffmpeg/trunk
* RA144: work around gcc bug/oddity on ARMMåns Rullgård2009-03-01
| | | | | | | | | This should not make any difference, yet some gcc versions on ARM produce incorrect output without this fix. Approved by Vitor. Originally committed as revision 17698 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Reindent after last commitVitor Sessak2009-03-01
| | | | Originally committed as revision 17678 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Do not read uninitialized buffer, no matter if it will be multiplied byVitor Sessak2009-03-01
| | | | | | | zero later. This should fix some valgrind warnings and hopefully FATE ra144 test on ARM. Originally committed as revision 17677 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split off celp_filters.[ch] from acelp_filters.[ch] for the QCELP decoder.Kenan Gillet2008-10-24
| | | | | | patch by Kenan Gillet, kenan.gillet gmail com Originally committed as revision 15680 to svn://svn.ffmpeg.org/ffmpeg/trunk
* misc spelling/wording/grammar fixesDiego Biurrun2008-09-11
| | | | Originally committed as revision 15296 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Normalize triplets in gain_val_tab[][] so gain_exp_tab[] can be just anVitor Sessak2008-09-08
| | | | | | one-dimensional array. Originally committed as revision 15273 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Pass directly variable 'a' to interp instead of evaluating it from num_blocksVitor Sessak2008-09-08
| | | | Originally committed as revision 15269 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify if() in copy_and_dup()Vitor Sessak2008-09-08
| | | | Originally committed as revision 15268 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add av_cold attribute to decode_init()Vitor Sessak2008-09-08
| | | | Originally committed as revision 15267 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: Make the two additional units in size more clearVitor Sessak2008-09-08
| | | | Originally committed as revision 15266 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Test a var for overflow just after it is setVitor Sessak2008-09-06
| | | | Originally committed as revision 15223 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove useless parentheses.Vitor Sessak2008-09-06
| | | | Originally committed as revision 15222 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: rename loop counters in eval_refl()Vitor Sessak2008-08-06
| | | | Originally committed as revision 14653 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify eval_refl(): do not store a buffer value in a var when the buffer ↵Vitor Sessak2008-08-06
| | | | | | could be used directly Originally committed as revision 14652 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify eval_refl(): s/b == 0/!b/Vitor Sessak2008-08-06
| | | | Originally committed as revision 14651 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify range checking in eval_refl(). Before theVitor Sessak2008-08-06
| | | | | | | | | condition b == 0 could never be true, because it would have already been caught in the previous ifs. Also the condition b == 0x1000 could never be true (it would triggered the return). Originally committed as revision 14650 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: reindentVitor Sessak2008-08-06
| | | | Originally committed as revision 14649 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify do_output_subblock(): Remove a unneeded memcpyVitor Sessak2008-08-06
| | | | Originally committed as revision 14648 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify eval_refl(): return directly when needed instead of storing the ↵Vitor Sessak2008-08-06
| | | | | | return value in a variable Originally committed as revision 14640 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify rms(): merge a few operations in the same statementVitor Sessak2008-08-06
| | | | Originally committed as revision 14639 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetical simplification in t_sqrt()Vitor Sessak2008-08-06
| | | | Originally committed as revision 14638 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Check available size before writing in decode_frame()Vitor Sessak2008-08-06
| | | | Originally committed as revision 14637 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Modify all codecs to report their supported input and output sample format(s).Peter Ross2008-07-31
| | | | Originally committed as revision 14482 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: rename loop counter vars to i,jVitor Sessak2008-07-29
| | | | Originally committed as revision 14467 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make ff_acelp_lp_synthesis_filter() receives a pointer to the actual filter ↵Vitor Sessak2008-06-29
| | | | | | coefficients and not the pointer minus one Originally committed as revision 14031 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Update copyrightVitor Sessak2008-06-29
| | | | Originally committed as revision 14030 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use ff_acelp_lp_synthesis_filter() instead of duplicating itVitor Sessak2008-06-29
| | | | Originally committed as revision 14029 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Doxy commentVitor Sessak2008-06-29
| | | | Originally committed as revision 14026 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Simplify interp()Vitor Sessak2008-06-24
| | | | Originally committed as revision 13953 to svn://svn.ffmpeg.org/ffmpeg/trunk
* More cosmeticsVitor Sessak2008-06-24
| | | | Originally committed as revision 13952 to svn://svn.ffmpeg.org/ffmpeg/trunk
* CosmeticsVitor Sessak2008-06-24
| | | | Originally committed as revision 13951 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use lpc_coef[2] instead of lpc_coef and lpc_coef_oldVitor Sessak2008-06-24
| | | | Originally committed as revision 13946 to svn://svn.ffmpeg.org/ffmpeg/trunk