summaryrefslogtreecommitdiff
path: root/libavcodec/mathops.h
Commit message (Collapse)AuthorAge
* lavc: Deduplicate zigzag_scan tableDiego Biurrun2016-03-25
|
* dsputil: Move ff_zigzag_direct and ff_crop_tab declarations to mathops.hDiego Biurrun2014-03-22
|
* mathops: move macro to the only place it is usedVittorio Giovara2014-03-04
| | | | This helps in disentangling lavf and lavc too.
* lavc: add ff_u8_to_s8() for safe type punning of uint8_t to int8_tJustin Ruggles2013-09-18
|
* mpegts: Remove one 64-bit integer modulus operation per packetBen Avison2013-08-05
| | | | | | | | | | | | | The common case of the pointer having increased by one packet (which results in no change to the modulus) can be detected with a 64-bit subtraction, which is far cheaper than a division on many platforms. Before After Mean StdDev Mean StdDev Change Divisions 248.3 8.8 51.5 7.4 +381.7% Overall 2773.2 25.6 2372.5 43.1 +16.9% Signed-off-by: Martin Storsjö <martin@martin.st>
* Move av_reverse table to libavcodecDiego Biurrun2012-10-12
| | | | It is only used in that library.
* Move avutil tables only used in libavcodec to libavcodec.Diego Biurrun2012-10-11
|
* Move MASK_ABS macro to libavcodec/mathops.hMans Rullgard2012-08-09
| | | | | | | | | | | | This macro is only used in two places, both in libavcodec, so this is a more sensible place for it. Two small tweaks to the macro are made: - removing the trailing semicolon - dropping unnecessary 'volatile' from the x86 asm Signed-off-by: Mans Rullgard <mans@mansr.com>
* cosmetics: Remove extra newlines at EOFAlex Converse2012-01-27
|
* mathops: remove undefined behaviour from sign_extend()Mans Rullgard2011-10-13
| | | | | | | | This function intentionally overflows the signed range on the left shift. Using this type-punning avoids errors from the overflow checker without disabling this test globally. Signed-off-by: Mans Rullgard <mans@mansr.com>
* mathops: use MUL64 macro where it forms part of other opsMans Rullgard2011-06-04
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add missing #includes to make headers self-contained.Diego Biurrun2011-06-04
| | | | This fixes 'make checkheaders'.
* mathops: remove ancient confusing commentMans Rullgard2011-05-16
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add more int packing macros, name them consistentlyMåns Rullgård2010-06-30
| | | | Originally committed as revision 23916 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename PACK4x8() to PACK4UINT8().Ronald S. Bultje2010-06-22
| | | | Originally committed as revision 23721 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add a macro to pack 4 bytes into native byte-order so they can be writtenRonald S. Bultje2010-06-22
| | | | | | at once using a single 32-bit store. Originally committed as revision 23715 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use standard C for implementing sign_extend() and zero_extend().Michael Niedermayer2010-05-13
| | | | | | This fixes compilation of probetest Originally committed as revision 23116 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add zero_extend() functionMåns Rullgård2010-02-21
| | | | Originally committed as revision 21947 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move NEG_[US]SR32 macros to mathops.hMåns Rullgård2010-02-17
| | | | Originally committed as revision 21873 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add UMULH()Måns Rullgård2010-01-26
| | | | | | | This function/macro returns the high half of the unsigned 64-bit product of two unsigned 32-bit operands. Originally committed as revision 21463 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move COPY3_IF_LT to lavc/mathops.hMåns Rullgård2010-01-20
| | | | | | | | This obscure macro is only used in motion_est.c so having it in lavc makes more sense. See discussion here: http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2008-November/056561.html Originally committed as revision 21346 to svn://svn.ffmpeg.org/ffmpeg/trunk
* AVR32: optimised mathops.hMåns Rullgård2009-08-17
| | | | | | 44% faster MP3 decoding Originally committed as revision 19667 to svn://svn.ffmpeg.org/ffmpeg/trunk
* MIPS: add MIPS64 and Loongson asm for MAC64/MLS64Måns Rullgård2009-05-28
| | | | Originally committed as revision 18979 to svn://svn.ffmpeg.org/ffmpeg/trunk
* mathops: sort arch-specific #include linesMåns Rullgård2009-05-20
| | | | Originally committed as revision 18886 to svn://svn.ffmpeg.org/ffmpeg/trunk
* mathops: whitespace cosmeticsMåns Rullgård2009-05-20
| | | | Originally committed as revision 18885 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add sign_extend() function to mathops.hMåns Rullgård2009-03-03
| | | | Originally committed as revision 17738 to svn://svn.ffmpeg.org/ffmpeg/trunk
* re-enable mid_pred asm on x86_64. (broke in r16681)Loren Merritt2009-02-08
| | | | Originally committed as revision 17058 to svn://svn.ffmpeg.org/ffmpeg/trunk
* cosmetics: Remove pointless period after copyright statement non-sentences.Diego Biurrun2009-01-19
| | | | Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
* moves mid_pred() into mathops.h (with arch specific code split by directory)Aurelien Jacobs2009-01-18
| | | | Originally committed as revision 16681 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change semantic of CONFIG_*, HAVE_* and ARCH_*.Aurelien Jacobs2009-01-13
| | | | | | They are now always defined to either 0 or 1. Originally committed as revision 16590 to svn://svn.ffmpeg.org/ffmpeg/trunk
* consistency cosmetics: Rename POWERPC identifiers to PPC.Diego Biurrun2008-12-27
| | | | Originally committed as revision 16359 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Rename libavcodec/i386/ --> libavcodec/x86/.Diego Biurrun2008-12-22
| | | | | | | It contains optimizations that are not specific to i386 and libavutil uses this naming scheme already. Originally committed as revision 16270 to svn://svn.ffmpeg.org/ffmpeg/trunk
* ARM: replace "armv4l" with "arm"Måns Rullgård2008-12-17
| | | | Originally committed as revision 16179 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add shift argument to MULL() macroMåns Rullgård2008-11-24
| | | | | | | | This replaces use of FRAC_BITS in the MULL() definition with a third argument specifying the shift amount. All uses of this macro are updated to pass FRAC_BITS as third argument. Originally committed as revision 15921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Globally rename the header inclusion guard names.Stefano Sabatini2008-08-31
| | | | | | | | | Consistently apply this rule: the guard name is obtained from the filename by stripping the leading "lib", converting '/' and '.' to '_' and uppercasing the resulting name. Guard names in the root directory have to be prefixed by "FFMPEG_". Originally committed as revision 15120 to svn://svn.ffmpeg.org/ffmpeg/trunk
* mathops: add MAC64, MLS64, and MLS16Måns Rullgård2008-07-13
| | | | | | | | MAC64: 64 += 32 x 32 (bits) MLS64: 64 -= 32 x 32 MLS16: 32 -= 16 x 16 Originally committed as revision 14198 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use full path for #includes from another directory.Diego Biurrun2008-05-09
| | | | Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
* fix typo ARCH_PPC -> ARCH_POWERPCMåns Rullgård2008-03-17
| | | | Originally committed as revision 12465 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add FFMPEG_ prefix to all multiple inclusion guards.Diego Biurrun2007-10-17
| | | | Originally committed as revision 10765 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Hooking bfin/mathops.hMarc Hoffman2007-08-30
| | | | Originally committed as revision 10263 to svn://svn.ffmpeg.org/ffmpeg/trunk
* include all prerequisites in header filesMåns Rullgård2007-06-16
| | | | Originally committed as revision 9344 to svn://svn.ffmpeg.org/ffmpeg/trunk
* rename always_inline to av_always_inline and move to common.hMåns Rullgård2006-12-08
| | | | Originally committed as revision 7256 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add ARCH_X86_32 as a new define for 32 bit x86 architectures and changeDiego Biurrun2006-11-01
| | | | | | the semantics of ARCH_X86 to mean both 32 and 64 bits. Originally committed as revision 6852 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change license headers to say 'FFmpeg' instead of 'this program/this library'Diego Biurrun2006-10-07
| | | | | | and fix GPL/LGPL version mismatches. Originally committed as revision 6577 to svn://svn.ffmpeg.org/ffmpeg/trunk
* New single instruction math operation headerLuca Barbato2006-09-19
Originally committed as revision 6291 to svn://svn.ffmpeg.org/ffmpeg/trunk