summaryrefslogtreecommitdiff
path: root/libavcodec/lclenc.c
Commit message (Collapse)AuthorAge
* cosmetics: Drop particularly redundant silly commentsDiego Biurrun2016-02-18
|
* cosmetics: Drop empty comment linesDiego Biurrun2016-02-18
|
* Deprecate avctx.coded_frameVittorio Giovara2015-07-20
| | | | | | | | | | | | | | | | | The rationale is that coded_frame was only used to communicate key_frame, pict_type and quality to the caller, as well as a few other random fields, in a non predictable, let alone consistent way. There was agreement that there was no use case for coded_frame, as it is a full-sized AVFrame container used for just 2-3 int-sized properties, which shouldn't even belong into the AVCodecContext in the first place. The appropriate AVPacket flag can be used instead of key_frame, while quality is exported with the new AVPacketSideData quality factor. There is no replacement for the other fields as they were unreliable, mishandled or just not used at all. Signed-off-by: Vittorio Giovara <vittorio.giovara@gmail.com>
* Gather all coded_frame allocations and free functions to a single placeVittorio Giovara2015-07-20
| | | | | | | | | | | | | | Allocating coded_frame is what most encoders do anyway, so it makes sense to always allocate and free it in a single place. Moreover a lot of encoders freed the frame with av_freep() instead of the correct API av_frame_free(). This bring uniformity to encoder behaviour and prevents applications from erroneusly accessing this field when not allocated. Additionally this helps isolating encoders that export information with coded_frame, and heavily simplifies its deprecation. Signed-off-by: Vittorio Giovara <vittorio.giovara@gmail.com>
* lcl: Check memory allocationVittorio Giovara2015-05-31
|
* lclenc: Mark codec as init-thread-safe and init-cleanupVittorio Giovara2015-04-24
|
* lcl: return an appropriate error codeVittorio Giovara2014-12-18
|
* lclenc: use the AVFrame API properly.Anton Khirnov2013-11-16
|
* cosmetics: Group .name and .long_name together in codec/format declarationsDiego Biurrun2013-10-03
|
* Replace PIX_FMT_* -> AV_PIX_FMT_*, PixelFormat -> AVPixelFormatAnton Khirnov2012-10-08
|
* Don't include common.h from avutil.hMartin Storsjö2012-08-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* cosmetics: Align codec declarationsMartin Storsjö2012-04-06
| | | | | | | Also break some long lines, remove codec function placeholder comments and add spaces in sample/pixel format lists. Signed-off-by: Martin Storsjö <martin@martin.st>
* lclenc: switch to encode2().Anton Khirnov2012-02-23
|
* lavc: use designated initialisers for all codecs.Anton Khirnov2011-07-29
| | | | It's more readable and less prone to breakage.
* Replace deprecated FF_*_TYPE symbols with AV_PICTURE_TYPE_*.Stefano Sabatini2011-05-02
| | | | Signed-off-by: Diego Biurrun <diego@biurrun.de>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add ff_ prefix to data symbols of encoders, decoders, hwaccel, parsers, bsf.Diego Elio Pettenò2011-01-26
| | | | | | | None of these symbols should be accessed directly, so declare them as hidden. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add .pix_fmts to LCL encoderJason Garrett-Glaser2010-12-31
| | | | | | Now ffmpeg should automatically convert to BGR instead of erroring out. Originally committed as revision 26178 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove unnecessary put_bits/get_bits includes.Reimar Döffinger2009-05-31
| | | | Originally committed as revision 19052 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove now unused elements from LclEncContextReimar Döffinger2009-05-31
| | | | Originally committed as revision 19032 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove useless casts, extradata is already "uint8_t *"Reimar Döffinger2009-05-31
| | | | Originally committed as revision 19031 to svn://svn.ffmpeg.org/ffmpeg/trunk
* lclenc.c: compress directly into output buffer instead of using a pointlessReimar Döffinger2009-05-31
| | | | | | temporary buffer and then using put_bits to copy the data over. Originally committed as revision 19030 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove superfluous () from lclenc.cReimar Döffinger2009-05-31
| | | | Originally committed as revision 19028 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Cosmetics: fix indentation in lclenc.cReimar Döffinger2009-05-31
| | | | Originally committed as revision 19027 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove "#if CONFIG_ZLIB" checks from lclenc.c, the file is never compiledReimar Döffinger2009-05-31
| | | | | | if zlib is not available. Originally committed as revision 19026 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Split bitstream.h, put the bitstream writer stuff in the new fileStefano Sabatini2009-04-12
| | | | | | put_bits.h. Originally committed as revision 18461 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Use full internal pathname in doxygen @file directives.Diego Biurrun2009-02-01
| | | | | | | Otherwise doxygen complains about ambiguous filenames when files exist under the same name in different subdirectories. Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Fix filenames in Doxygen comments.Diego Biurrun2009-01-26
| | | | Originally committed as revision 16811 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Change semantic of CONFIG_*, HAVE_* and ARCH_*.Aurelien Jacobs2009-01-13
| | | | | | They are now always defined to either 0 or 1. Originally committed as revision 16590 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Bump Major version, this commit is almost just renaming bits_per_sample toLuca Abeni2008-09-08
| | | | | | | | | | | bits_per_coded_sample but that cannot be done seperately. Patch by Luca Abeni Also reset the minor version and fix the forgotton change to libfaad. Note: The API/ABI should not be considered stable yet, there still may be a change done here or there if some developer has some cleanup ideas and patches! Originally committed as revision 15262 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Improve an lclenc.c error message in case of unsupported input pixelStefano Sabatini2008-06-19
| | | | | | format. Originally committed as revision 13811 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make AVCodec long_names definition conditional depending on CONFIG_SMALL.Stefano Sabatini2008-06-12
| | | | Originally committed as revision 13759 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Add long names to AVCodec declarations.Stefano Sabatini2008-04-27
| | | | | | patch by Stefano Sabatini, stefano.sabatini-lala poste it Originally committed as revision 13009 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Apply 'cold' attribute to init/uninit functions in libavcodecZuxy Meng2008-03-21
| | | | Originally committed as revision 12525 to svn://svn.ffmpeg.org/ffmpeg/trunk
* split lcl.c into lcldec.c, lclenc.c, lcl.hMåns Rullgård2007-07-12
Originally committed as revision 9613 to svn://svn.ffmpeg.org/ffmpeg/trunk