summaryrefslogtreecommitdiff
path: root/libavcodec/binkaudio.c
Commit message (Collapse)AuthorAge
* lavc: Consistently prefix input buffer definesVittorio Giovara2015-07-27
| | | | Signed-off-by: Vittorio Giovara <vittorio.giovara@gmail.com>
* lavc: AV-prefix all codec capabilitiesVittorio Giovara2015-07-27
| | | | | | Express bitfields more simply. Signed-off-by: Vittorio Giovara <vittorio.giovara@gmail.com>
* lavc: remove unused traces of fmtconvert usageAnton Khirnov2015-02-28
| | | | | Those decoders have been switched to float output and so do not use fmtconvert anymore.
* avcodec: Don't anonymously typedef structsDiego Biurrun2015-02-14
|
* build: Split WMA frequencies into a separate object fileDiego Biurrun2014-09-04
| | | | | These are the only WMA bits shared with binkaudio. Splitting them off reduces the binnkaudio dependency on general WMA code.
* cosmetics: Group .name and .long_name together in codec/format declarationsDiego Biurrun2013-10-03
|
* avcodec: Replace local extern declarations for tables with header #includesDiego Biurrun2013-08-15
|
* lavc decoders: work with refcounted frames.Anton Khirnov2013-03-08
|
* Remove unnecessary dsputil.h #includesDiego Biurrun2013-02-26
|
* binkaudio: decode directly to the user-provided AVFrameJustin Ruggles2013-02-12
|
* lavc: add a wrapper for AVCodecContext.get_buffer().Anton Khirnov2012-12-04
| | | | It will be useful in the upcoming transition to refcounted AVFrames.
* binkaudio: set channel layoutJustin Ruggles2012-11-12
|
* binkaudio: remove unneeded GET_BITS_SAFE macroJustin Ruggles2012-09-18
| | | | Normal get_bits() already has overread protection.
* binkaudio: use float sample formatJustin Ruggles2012-09-18
| | | | Use planar for DCT codec, interleaved for RDFT codec.
* binkaudio: use a different value for the coefficient scale for the DCT codecJustin Ruggles2012-09-18
| | | | Eliminates the need for vector_fmul_scalar() in each frame.
* Replace all CODEC_ID_* with AV_CODEC_ID_*Anton Khirnov2012-08-07
|
* cosmetics: Align codec declarationsMartin Storsjö2012-04-06
| | | | | | | Also break some long lines, remove codec function placeholder comments and add spaces in sample/pixel format lists. Signed-off-by: Martin Storsjö <martin@martin.st>
* dsputil: Add ff_ prefix to the dsputil*_init* functionsMartin Storsjö2012-02-15
| | | | Signed-off-by: Martin Storsjö <martin@martin.st>
* Drop ALT_ prefix from BITSTREAM_READER_LE name.Diego Biurrun2011-12-22
| | | | | The prefix is a historic remnant that probably meant "alternative". Now that the A32 bitstream reader has been dropped it makes no sense anymore.
* lavu: replace int/float punning functionsMans Rullgard2011-12-11
| | | | | | | | | | | | | | | | | | The existing functions defined in intfloat_readwrite.[ch] are both slow and incorrect (infinities are not handled). This introduces a new header with fast, inline conversion functions using direct union punning assuming an IEEE-754 system, an assumption already made throughout the code. The one use of Intel/Motorola extended 80-bit format is replaced by simpler code sufficient under the present constraints (positive normal values). The old functions are marked deprecated and retained for compatibility. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Add avcodec_decode_audio4().Justin Ruggles2011-12-02
| | | | | | Deprecate avcodec_decode_audio3(). Implement audio support in avcodec_default_get_buffer(). Implement the new audio decoder API in all audio decoders.
* binkaudio: expand quant_table to accommodate all possible valuesJustin Ruggles2011-11-04
|
* binkaudio: change short to int16_tJustin Ruggles2011-10-29
|
* binkaudio: only decode one block at a time.Justin Ruggles2011-10-29
| | | | | This prevents truncating output due to an output buffer that is too small for all blocks. There is no limit on the number of blocks in a packet.
* binkaudio: store interleaved overlap samples in BinkAudioContext.Justin Ruggles2011-10-29
| | | | | This fixes the requirement for the buffer size to be larger than the number of samples actually decoded.
* binkaudio: pre-calculate quantization factorsJustin Ruggles2011-10-29
|
* binkaudio: add some buffer overread checks.Justin Ruggles2011-10-29
| | | | This stops decoding before overreads instead of after.
* lavc: use designated initialisers for all codecs.Anton Khirnov2011-07-29
| | | | It's more readable and less prone to breakage.
* bink: pass Bink version to audio decoder through extradata instead of codec_tag.Kostya2011-07-06
| | | | | | | This is needed because not all players (e.g. MPlayer) are able to distinguish two different Bink audio decoders when codec_tag is set. Signed-off-by: Anton Khirnov <anton@khirnov.net>
* Add AVX FFT implementation.Vitor Sessak2011-04-26
| | | | Signed-off-by: Reinhard Tartler <siretart@tauware.de>
* Move dct and rdft definitions to separate filesMans Rullgard2011-03-20
| | | | | | | This leaves fft.h with only the core FFT and MDCT definitions thus making it more managable. Signed-off-by: Mans Rullgard <mans@mansr.com>
* fft: remove inline wrappers for function pointersMans Rullgard2011-03-19
| | | | | | | This removes the rather pointless wrappers (one not even inline) for calling the fft_calc and related function pointers. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace FFmpeg with Libav in licence headersMans Rullgard2011-03-19
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* Bink version 'b' audio decoderPeter Ross2011-02-25
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* binkaudio: simplify frame_len_bits and frame_len calculationPeter Ross2011-02-25
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* binkaudio: remove unnecessary loopPeter Ross2011-02-25
| | | | | | | decode_init sets bands[0] == 2, so this loop always sets the band table index (k) to zero. Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* binkaudio: perform band table scaling in decode_initPeter Ross2011-02-25
| | | | Signed-off-by: Ronald S. Bultje <rsbultje@gmail.com>
* binkaudio: remove unused copy of AVCodecContext*Peter Ross2011-02-15
| | | | Signed-off-by: Mans Rullgard <mans@mansr.com>
* binkaudio: fix channel count checkPeter Ross2011-02-15
| | | | | | | | | Perform validity check on AVFormatContext.channels instead of uninitialised field. This fixes issue 2001. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Separate format conversion DSP functions from DSPContext.Justin Ruggles2011-02-02
| | | | | | | This will be beneficial for use with the audio conversion API without requiring it to depend on all of dsputil. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Remove the add bias hack for the C version of DSPContext.float_to_int16_*().Justin Ruggles2011-01-28
|
* Add ff_ prefix to data symbols of encoders, decoders, hwaccel, parsers, bsf.Diego Elio Pettenò2011-01-26
| | | | | | | None of these symbols should be accessed directly, so declare them as hidden. Signed-off-by: Mans Rullgard <mans@mansr.com>
* Replace deprecated symbols SAMPLE_FMT_* with AV_SAMPLE_FMT_*, and enumStefano Sabatini2010-11-12
| | | | | | SampleFormat with AVSampleFormat. Originally committed as revision 25730 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove explicit filename from Doxygen @file commands.Diego Biurrun2010-04-20
| | | | | | | | Passing an explicit filename to this command is only necessary if the documentation in the @file block refers to a file different from the one the block resides in. Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make code using 1d-DCT consistent with the API changeVitor Sessak2010-04-03
| | | | Originally committed as revision 22792 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Define AVMediaType enum, and use it instead of enum CodecType, whichStefano Sabatini2010-03-30
| | | | | | is deprecated and will be dropped at the next major bump. Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Make binkaudio work with ff_float_to_int16_interleave_c (martin at martin ↵Peter Ross2010-03-11
| | | | | | dot st) Originally committed as revision 22466 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Give RDFT types more meaningful namesMåns Rullgård2010-03-07
| | | | Originally committed as revision 22290 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Move FFT parts from dsputil.h to fft.hMåns Rullgård2010-03-06
| | | | Originally committed as revision 22235 to svn://svn.ffmpeg.org/ffmpeg/trunk
* Remove DECLARE_ALIGNED_{8,16} macrosMåns Rullgård2010-03-06
| | | | | | | These macros are redundant. All uses are replaced with the generic DECLARE_ALIGNED macro instead. Originally committed as revision 22233 to svn://svn.ffmpeg.org/ffmpeg/trunk