summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 7c1a7e45..06c9fc22 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -887,6 +887,11 @@ CCTK_C_ATTRIBUTE_NOINLINE
CCTK_CXX_ATTRIBUTE_NOINLINE
CCTK_CXX_MEMBER_ATTRIBUTE_NOINLINE
+# Find out whether the C compiler supports __attribute__((always_inline))
+CCTK_C_ATTRIBUTE_ALWAYS_INLINE
+CCTK_CXX_ATTRIBUTE_ALWAYS_INLINE
+CCTK_CXX_MEMBER_ATTRIBUTE_ALWAYS_INLINE
+
# Find out whether the C compiler supports __attribute__((unused))
CCTK_C_ATTRIBUTE_UNUSED
CCTK_CXX_ATTRIBUTE_UNUSED
@@ -915,6 +920,12 @@ CCTK_FORTRAN_COMPLEX8
CCTK_FORTRAN_COMPLEX16
CCTK_FORTRAN_COMPLEX32
+# CCTK_FORTRAN_CRAY_POINTERS
+# if test "$cctk_cv_have_fortran_cray_pointers" = "no" ; then
+# echo 'Fortran Cray pointers are not supported'
+# exit 1
+# fi
+
dnl Do we whave __cxa_demangle
AC_LANG_SAVE
AC_LANG_CPLUSPLUS