summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 41d412d1..08ae04f3 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -499,6 +499,14 @@ dnl Checks for header files.
AC_HEADER_STDC
+dnl Check for C99
+
+CCTK_CHECK_C99
+if test "$cctk_cv_have_c99" = "no" ; then
+ echo "Cactus requires a C99 compiler -- check your C compiler and C compiler flags"
+ exit 1
+fi
+
dnl Checks for typedefs, structures, and compiler characteristics.
if test "x$cross_compiling" = 'xno' ; then