summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index b97e6ed8..5bd8c2a5 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -20,7 +20,7 @@ AC_INIT()
AC_CONFIG_HEADER(cctk_Config.h)
dnl Check the system type
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_HOST
# See if there are any preferred compilers for this system
@@ -247,6 +247,14 @@ AC_C_INLINE
# Check for sizes of integer types
if test "x$cross_compiling" = "xyes"; then
+ if test -z "$SIZEOF_LONG_LONG" ; then
+ AC_MSG_ERROR(Cross-compiling - no value set for sizeof(long long) please set SIZEOF_LONG_LONG)
+ fi
+fi
+
+AC_CHECK_SIZEOF(long long, $SIZEOF_LONG_LONG)
+
+if test "x$cross_compiling" = "xyes"; then
if test -z "$SIZEOF_LONG_INT" ; then
AC_MSG_ERROR(Cross-compiling - no value set for sizeof(long int) please set SIZEOF_LONG_INT)
fi
@@ -491,6 +499,15 @@ AC_SUBST(EXE)
# Integer types
+case "x$ac_cv_sizeof_long_long" in
+ "x8")
+ CCTK_INT8="long long" ;;
+ "x4")
+ CCTK_INT4="long long" ;;
+ "x2")
+ CCTK_INT2="long long" ;;
+esac
+
case "x$ac_cv_sizeof_long_int" in
"x8")
CCTK_INT8="long int" ;;