summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 6ddfb8d0..1850c5e7 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -808,6 +808,11 @@ CCTK_C__PRAGMA
#CCTK_CXX_ATTRIBUTE_PURE
#CCTK_CXX_MEMBER_ATTRIBUTE_PURE
+# Find out whether the C compiler supports __attribute__((noinline))
+CCTK_C_ATTRIBUTE_NOINLINE
+CCTK_CXX_ATTRIBUTE_NOINLINE
+CCTK_CXX_MEMBER_ATTRIBUTE_NOINLINE
+
# Find out whether the C compiler supports __attribute__((unused))
CCTK_C_ATTRIBUTE_UNUSED
CCTK_CXX_ATTRIBUTE_UNUSED
@@ -819,6 +824,7 @@ CCTK_CXX_ATTRIBUTE_UNUSED
## Find out whether the C compiler supports __attribute__((hot))
#CCTK_C_ATTRIBUTE_HOT
#CCTK_CXX_ATTRIBUTE_HOT
+
CCTK_FORTRAN_REAL4
CCTK_FORTRAN_REAL8
CCTK_FORTRAN_REAL16