summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-10-31 21:10:59 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2000-10-31 21:10:59 +0000
commitf7c3c19b8b32a48bf5c7c0e1235f9fb4ab04446c (patch)
tree336064b79e9471ab8f387d8204a39aa7375eccbd /lib/make/configure.in
parente3888f521cd388f8e5199459cc4de7d20bf1472c (diff)
Added LIBNAME_PREFIX and LIBNAME_SUFFIX to allow libraries to be named
differently on some architectures (e.g. NT). Removed fallback definition for GENERAL_LIBRARIES in make.configuration, and added fallback definitions for LIBNAME_PREFIX and LIBNAME_SUFFIX so old configurations should still work. Tom git-svn-id: http://svn.cactuscode.org/flesh/trunk@1872 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 4a1d3e69..06af3ea2 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -898,6 +898,12 @@ AC_SUBST(OPTIONSEP)
: ${OPTIONSEP='$(EMPTY_VAR) # a single space'}
+# How to name libraries for this system
+AC_SUBST(LIBNAME_PREFIX)
+: ${LIBNAME_PREFIX='lib'}
+AC_SUBST(LIBNAME_SUFFIX)
+: ${LIBNAME_SUFFIX='.a'}
+
# How to link the cactus libraries
AC_SUBST(CACTUSLIBLINKLINE)
@@ -979,6 +985,7 @@ AC_SUBST(SYS_INC_DIRS)
AC_SUBST(GENERAL_LIBRARIES)
: ${GENERAL_LIBRARIES='$(LIBDIRS:%=-L%) $(LIBS:%=-l%)'}
+
# Do we need to make sure Perl makes a backup when editting in place ?
AC_SUBST(PERL_BACKUP_NECESSARY)