summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorknarf <knarf@17b73243-c579-4c4c-a9d2-2d5706c11dac>2011-03-16 15:10:54 +0000
committerknarf <knarf@17b73243-c579-4c4c-a9d2-2d5706c11dac>2011-03-16 15:10:54 +0000
commite46b96579173142641d60f6b4ced41c44968927a (patch)
tree738902b58f970d8a0a0c2505b7af3c28f67e0ad3 /lib/make/configure.in
parentf1549a3d0422266fa142f241c413104c3366bb51 (diff)
let Cactus search for TAR GZIP PATCH and GIT while configuring
git-svn-id: http://svn.cactuscode.org/flesh/trunk@4688 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 2460b99a..2bba5837 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -201,6 +201,22 @@ if test -z "$PERL" ; then
AC_CHECK_PROGS(PERL, perl)
fi
+if test -z "$TAR" ; then
+ AC_CHECK_PROGS(TAR, gtar tar)
+fi
+
+if test -z "$GZIP" ; then
+ AC_CHECK_PROGS(GZIP, gzip)
+fi
+
+if test -z "$PATCH" ; then
+ AC_CHECK_PROGS(PATCH, gpatch patch)
+fi
+
+if test -z "$GIT" ; then
+ AC_CHECK_PROGS(GIT, git)
+fi
+
if test -z "$F90" ; then
AC_CHECK_PROGS(F90, f90 pgf90 xlf90 ifort gfortran-mp-4.4 gfortran-mp-4.3 gfortran-mp-4.2 gfortran)
fi