summaryrefslogtreecommitdiff
path: root/lib/make/configure.in
diff options
context:
space:
mode:
authorgoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-04 10:48:14 +0000
committergoodale <goodale@17b73243-c579-4c4c-a9d2-2d5706c11dac>2005-10-04 10:48:14 +0000
commite076f0a4f2c6544b82c057476fd713d37989852a (patch)
tree3b0af0a80cc492001a8c5f0f05dbe5819aa13e8d /lib/make/configure.in
parentd51b12875913e37cdd43f7ef1c67039bdd4b85f6 (diff)
Reverse changes made in version 1.133 to enable separate F77 and F90
compilers --- this caused problems on an SP system and also needs to ensure that F90 and F77 naming schemes are the same. git-svn-id: http://svn.cactuscode.org/flesh/trunk@4164 17b73243-c579-4c4c-a9d2-2d5706c11dac
Diffstat (limited to 'lib/make/configure.in')
-rw-r--r--lib/make/configure.in6
1 files changed, 2 insertions, 4 deletions
diff --git a/lib/make/configure.in b/lib/make/configure.in
index 45d204cc..5cbe90fc 100644
--- a/lib/make/configure.in
+++ b/lib/make/configure.in
@@ -133,7 +133,6 @@ if test -z "$F90" ; then
AC_CHECK_PROGS(F90, f90 pgf90 xlf90 ifort)
fi
-USER_F77="$F77"
if test -z "$F77" ; then
AC_CHECK_PROGS(F77, f77 pgf77 g77 f90 pgf90 xlf90 ifort)
fi
@@ -201,9 +200,8 @@ CCTK_WriteLine cctk_Archdefs.h '#endif /* _CCTK_ARCHDEFS_H_ */'
#########################################################################
# Deal with the Fortran compiler issues.
-# If there's a Fortran 90 compiler, and if the user hasn't explicitly
-# specified a Fortran 77 compiler, use that for all the Fortran.
-if test "x$USER_F77" = 'x' -a "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
+# If there's a Fortran 90 compiler use that for all the Fortran.
+if test "x$F90" != 'x' -a "x$F90" != 'xnone' -a "x$F77" != 'xnone' ; then
F77=$F90
: {F77FLAGS=$F90FLAGS}
fi